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Purpose
Material Requirements Planning (MRP) enables you to plan material requirements for a manufacturing
or procurement process.
MRP calculates gross requirements for the highest Bill of Materials (BOM) level based on sales
orders, production orders, forecasts, and so on. It calculates gross requirements at the lowest BOM
levels by carrying down net parent demands through the BOM structure. Dependent levels may have
their own requirements based on sales orders and forecasts.
The results of the MRP run are recommendations that fulfill gross requirements by taking into
consideration the existing inventory levels, existing purchase orders, and production orders. The MRP
run also takes into account defined planning rules for Order Multiple, Order Interval, and Minimum
Order Quantity.
Recommendations are back-scheduled by the defined lead time to arrive at the requirement dates for
their own components.
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The MRP Process in SAP Business One

SAP Business One lets you divide the MRP run into equal periods of time (for example, weeks or
days). The process always starts with the parent item in the highest level and ends with the last child
item.

Procedure
For every given time period, MRP performs the planning process in the order described below:

Calculations for the Parent Item
...

1. MRP calculates the quantity required to continue the sales of the final product without any
delays, considering all the resources:
{

Initial inventory (quantity on hand)

{

Receipts: purchase orders, production orders (for the parent item)

SAP Business One then subtracts the following requirements:
{

Sales order

{

Forecast

{

Production order (for the child items)

{

A/R reserve invoice
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2. SAP Business One uses the planning policy to make the production or purchase order
recommendations. The planning policy is based on:
{

Lead time

{

Minimum amount

{

Multiples

{

Time intervals
Note
All the above parameters are defined in the Item Master Data window. For more
information, see Defining Initial Settings.

3. After the calculation is completed, SAP Business One issues recommendations to create
production orders for the parent item.
4. To complete the production orders for the parent item, quantities of the child items that comprise
the BOM are needed. SAP Business One calculates the quantity of the child items, considering
the MRP-dependent requirements. SAP Business One then recommends the creation of
purchase orders or production orders for the child items required to produce the parent item.

Calculations for the Child Item
1. SAP Business One calculates the quantity required to continue the sales of the final product
without any delays, considering the following resources:
{

Initial inventory (on hand quantity)

{

Receipts (similar to the calculation for the parent item)

SAP Business One then subtracts the following requirements:
{

All the requirements specified above (similar to the calculation for the parent item)

{

MRP Dependent Requirement – The quantities of child items required to complete the
production orders recommended by MRP for the parent item (requirements for the child
items calculated during the MRP run)

2. SAP Business One uses the planning policy to make the production or purchase order
recommendations, similar to the calculation for the parent item.
After the calculation is completed, SAP Business One issues recommendations for production
orders or purchase orders for the child items.
Note



The process continues in the same manner if the child item has child items of its
own and ends at the lowest level of the BOM.



A Disassembly Production Order appears in the requirements for the parent item
and in the receipts for the child item.
Example



1 piece of the parent item BOM is assembled from 2 pieces of a child item.



1 piece of the child item is assembled from 2 pieces of a grandchild item.

After the MRP run, SAP Business One issues a production order recommendation for 2
pieces of the parent item. In addition, SAP Business One adds the dependent
requirement of 4 pieces for the child item and 8 pieces of the grandchild item.
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Defining Initial Settings
To start using the MRP module, you need to make several initial definitions.

Setting the Item Master Data Window
Procedure
1. From the SAP Business One Main Menu, choose Inventory → Item Master Data → Planning
Data tab.

2. Specify the following information related to MRP and production:
Field

Activity/Description

Planning Method

Determine which items to include in
the MRP process:
•

Comments

MRP
Select this option to include the
item in the MRP process.

•

None (default option)
Select this option for items that
should not be a part of the
MRP process. These items do
not appear in any relevant
reports.
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Field

Activity/Description

Procurement
Method

Select the acquisition method for the
MRP recommendations.
•

Make
Select this option if you want
MRP to generate
recommendations for
production orders.

•

Buy
Select this option to generate
MRP recommendations for
purchase orders. This option is
suitable mainly for the child
items in the lowest level of the
BOM or for items that are not
part of a BOM.

Comments
Note
You need to define all parent items,
regardless of their type, with the
Make procurement method to
calculate the requirements for their
child items for the MRP run. For
sales or assembly BOMs, SAP
Business One does not issue an
actual production order for the parent
item. It issues only the requirements
for its child items (either production or
purchase orders, according to the
procurement method of the child
items).
Example
See Appendix: Example:
Procurement Method.

Order Interval

Select one of the existing values to
define time intervals between
different orders. To create a new
order interval, select Define New.
For more details, see Inventory
Cycles – Setup Window.

The Order Interval field represents
the time interval between one order
and another for the MRP
requirements calculations.
Example
If a weekly interval is chosen, MRP
issues the necessary orders no more
than once a week, grouping all of the
recommendations for a current week
into one order.

Order Multiple

Set a multiplication factor for ordering
the item.

Example
If you enter 5 in this field and 14
items are required, MRP
recommends ordering 15 items
(3X5=15). If 18 items are required,
the recommendation is to order 20
items (4X5).

Minimum Order
Qty

Specify a minimum quantity for
ordering items by MRP.

Lead Time

Specify the number of days it takes to
produce or obtain an item.

Example
If 3 days are required to produce a
certain parent item, MRP issues a
purchase or production order for the
child items with a due date that is 3
days earlier than the due date of
producing the parent item.
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Note
You can also define Planning Data per Item Group in the Item Groups – Setup window
(Administration → Setup → Inventory → Item Groups → General tab).
3. Open the General tab in the Item Master Data window.
4. If you want to define the item as a bill of materials, which is not a production type, select the
Phantom Item checkbox.
A phantom item is similar to an assembly bill of materials; therefore, it cannot be defined as an
inventory item and it is not included in the Order Recommendation (see Creating Order
Recommendations).
5. To save your changes, choose the Update button.

Inventory Cycles – Setup Window
You use the Inventory Cycles – Setup window to define time intervals between different orders.

Procedure
1. From the SAP Business One Main Menu, choose Inventory → Item Master Data → Planning
Data tab.
2. In the Order Interval dropdown list, to open the Inventory Cycles – Setup window, choose Define
New.

3. Specify the following information:
Field

Activity/Description

Name

Enter a name for the interval.
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Field

Activity/Description

Frequency

Set the frequency of issuing orders:
•

Weekly
Select this option to define a weekly interval. This changes the field on
the right to a dropdown list containing the days of the week. Select the
required day on which you would like to issue orders.

•

Monthly
Select this option to define a monthly interval. This changes the field on
the right to a dropdown list containing the days in the month. Select the
required day in the month on which you would like to issue orders.

•

Every X days
Select this option to define an interval according to a certain number of
days. In this case, define the number of days in the field on the right.

4. To add the Order Interval to the system, choose the Add button.

Defining Warehouses
Procedure
1. From the SAP Business One Main Menu, choose Administration → Setup → Inventory →
Warehouses.
The Warehouses – Setup window opens.
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2. To define a warehouse as the default in the MRP wizard, select the Nettable checkbox.
If the checkbox is deselected, the warehouse appears in the list of warehouses in the MRP
wizard but MRP does not select it automatically.
3. To save your changes, choose the Add button.
Note
Drop-ship warehouses cannot be defined as Nettable and, thus, cannot be part of the
MRP run.

Defining Forecasts
In many cases, production companies receive sales orders at short notice. However, the production
process might take a great deal of time. As a result, it is common for these companies to plan their
purchasing and production in advance, even before they receive actual sales orders. This is the goal
of a forecast. A forecast is designed to serve as an additional requirement. Therefore, the goods are
produced based on the forecast, and when the actual sales orders are received, the company is able
to supply the order at short notice.
Note
Although there is no restriction on the number of forecasts you can define, you can select
only one forecast for a single MRP scenario. For more information, see Using the MRP
Wizard.

Procedure
1. From the SAP Business One Main Menu, choose MRP → Forecasts.
The Forecasts window opens.
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2. Specify the following information related to the forecast:
Field

Activity/Description

Forecast Code

Specify a unique code for the forecast.

Forecast Name

Specify a relevant description for your forecast.

Start Date

Specify a start date for the forecast horizon.

Comments

Note that the date you specify
depends on the value selected
in the View field.
Example

End Date

Specify an end date for the forecast horizon.

View

Select the time period for managing the forecast.
Click the dropdown list and select Daily, Weekly,
or Monthly. The columns in the table change
respectively according to the selected option.
•

Daily
Select this option to divide the forecast into
days. When you select this option, SAP
Business One displays a column for each
day in the selected date range.

•

Weekly

•

If you enter July 15,
2009 as the start date
and the selected view is
Monthly, SAP Business
One changes the date
automatically to the
beginning of the month,
July 1, 2009.

•

If you enter August 15,
2009 as the End Date
and the selected view is
Monthly, SAP Business
One automatically
moves the end date to
the end of the month.

To select a Weekly view, you
should define holidays under
Administration → System
Initialization → Company
Details → Accounting Data →
Holidays.
Note
You cannot update the view
after adding the forecast.

Select this option to divide the forecast into
weeks. If you select this option, SAP
Business One displays the week number as
the column's name (52 weeks in a year).
•

Monthly
Select this option to divide the forecast into
months. When you select this option, SAP
Business One displays the name of the
month as the column's name.
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Note
Regardless of the selected view, MRP considers the requirements to the first day of the
period. For example, if you select a Weekly view, week number 23 starts on June 1,
2009 and ends on June 7, 2009, according to the Holidays definition of the company.
Therefore, the forecast relates to June 1, 2009, which is the beginning of the given week.
(Form Settings) →
3. To change the format for displaying the date in the forecast table, click
Document tab → General tab. Use the Columns Titles Style field to choose between two
formats:
{

Long – select this option to include the year in the column title.

{

Abbreviated – select this option to display only the day, week number, or month.

4. In the Item No. column, select the item numbers for which you would like to define forecasts.
The description for an item is automatically displayed in the Item Description column, according
to the definitions in the Item Master Data window.
5. Specify the quantities for every period in the items’ sales units. You can define Sales Units
under Inventory → Item Master Data → Sales Data tab → Sales UoM.
6. To save the forecast changes, choose the Add button.
Note
You can display additional fields by clicking
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Setting Sales Orders
MRP considers the forecast within the MRP horizon, checking whether sales orders already exist in
the forecast according to the method specified on the General Settings Inventory tab. For information,
see Configuring General Settings – Inventory Tab. MRP presents forecast requirements only for
quantities that have not yet been ordered; only the net forecast quantity is added to the requirements.

Procedure
1. To determine whether existing sales orders are reduced from the forecast, you need to open the
Sales Order window. From the SAP Business One Main Menu, choose Sales - A/R → Sales
Order.

2. To display the Consume Forecast field, click

(Form Settings).

3. Determine whether the forecast is 'consumed' by the Sales Order according to your selection In
the Consume Forecast field:
{

Yes – reduces the quantity specified in the sales order from the forecast.

{

No – prompts MRP to consider the sales order as an additional requirement.
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4. To add the document to the system, choose the Add button.
Note



You can also update this field after adding the document, but only if the row was
not copied to another document.



You can determine a default value for the Consume Forecast field using the
procedure in Configuring General Settings – Inventory Tab.

Configuring General Settings – Inventory Tab
1. From the SAP Business One Main Menu, choose Administration → System Initialization →
General Settings → Inventory tab → Planning tab.

2. Specify the following data:
Field

Activity/Description

Consume Forecast

Select this checkbox to set the value Yes as the
default value in the Consume Forecast field in all your
Sales Orders.
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Field

Activity/Description

Consumption
Method

To take quantities of items sold in sales orders into
account and to ensure that they are not included in
planned requirements, SAP Business One searches
for existing forecasts that are closest to the sales
order due date. Choose between two available
methods of forecast consumption:
•

Comments
Example
See Appendix:
Example:
Consumption Method.

Backward- Forward
First, SAP Business One searches previous
periods of time up to the first day of the required
range (as defined in the Days Backward field). If
no forecast is found (or the forecast that is
found is insufficient), SAP Business One
searches ahead starting from the sales order
due date.

•

Forward- Backward
First, SAP Business One searches ahead
starting from the sales order due date up to the
last day of the required range (as defined in the
Days Forward field). If no forecast is found (or
the forecast that is found is insufficient), SAP
Business One searches backward starting from
the sales order due date.

Days Backward

Specify the maximum number of days for SAP
Business One to search backward for a forecast, to
take into account quantities of items sold in sales
orders, so as to ensure they are not included in
planned requirements.

Days Forward

Specify the maximum number of days for SAP
Business One to search forward for a forecast, to take
into account quantities of items sold in sales orders,
so as to ensure that they are not included in planned
requirements.

3. To save your changes, choose the Update button.
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Using the MRP Wizard
The MRP wizard guides you through the process of defining new MRP scenarios and analyzing the
MRP results. Afterwards, SAP Business One generates and displays the MRP recommendations.

MRP Wizard Introduction Window
Procedure
1. From the SAP Business One Main Menu, choose MRP → MRP Wizard.
The MRP Wizard window opens.
2. Choose the Next button.

Step 1 – Select a New or Existing Scenario Window
The MRP Scenario is a set of parameters defined by the user which are applied during the MRP run.
You can define several MRP scenarios for each company, but only one scenario can be used for each
MRP run (MRP calculation of the production or purchase orders).
In the Select New or Existing Scenario window, select an existing MRP scenario or add a new
scenario.

Procedure
1. To add a new scenario, select Create New Scenario. When you choose this option, two new
fields appear:
{

Scenario Name – Specify a name for the new scenario. The name must be unique.

{

Description – Specify a description for the scenario.
Note
If no scenarios have been previously defined, the window opens in the Create New
Scenario mode by default.

2. To include an existing scenario from the list, choose Select Existing Scenario. When you choose
this option, a table appears that contains all the existing scenarios.
3. The last scenario used is highlighted by default. To choose a different scenario, click the
relevant row. The following information appears:
Field

Activity/Description

MRP Scenario Name

Displays the name of the MRP Scenario.

Description

Displays the description of the MRP scenario.

Start Date

Displays the first day of the first period of the
scenario.

End Date

Displays the last day of the last period of the
scenario.
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4. To execute the MRP run skipping the next steps, choose the Run button. This option is active
only when you choose an existing scenario.
Note
You cannot change the name of an existing scenario, but you can change its description
in the next window. You can reuse the name if you delete the MRP scenario.
To delete an existing scenario, select the scenario and from the menu bar and choose
Data → Remove.
5. To move on to the next step, choose the Next button; To go back to the previous step, choose
the Back button.

Step 2 – Scenario Details Window
In the Scenario Details window, you specify all the necessary parameters for the MRP run.

Procedure
1. Describe the MRP scenario.
You can use the current description or change it.
2. To define the scenario as a simulation scenario, select the Simulation checkbox.
You cannot save simulation scenario recommendations and release them.
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3. Set the Planning Horizon – the time period for the MRP run – from the first day of the MRP start
period until the last day of the MRP end period. Specify the following information:
Field

Activity/Description

Comments

View Data in
Periods of

Define the length of each period,
displayed in the MRP Results window, in
weeks or in days, depending on the
selected option.

If you choose to group into period
lengths other than 1 day, SAP
Business One performs the MRP
calculation on the first day of each
period. MRP groups all the existing
data for that period (receipts,
requirements) in the first day.

Example
If the value of the field is 4 weeks, then
each period in the MRP run represents 4
calendar weeks.

For weekly periods, the first day of
the week is defined according to the
holiday definition of the company.
Example
Period of 1 week is defined. A certain
week (week number 23) starts on
June 1, 2009 and ends on June 7,
2009, according to the holiday
definition of the company. MRP
performs the calculation for the entire
week as if all of the business activity
happened on June 1, 2009, which is
the beginning of the given week.

Start Date

Specify the first day of the first period.
When you use week periods, if the
selected date is in the middle of the
week, SAP Business One shifts it back to
the first day of the week. MRP considers
all the receipts and requirements that
have a Due Date from the Start Date and
later.

End Date

Specify the last day of the last period.
When using week periods MRP shifts the
date forward to the last day of the week.
MRP considers all the receipts and
requirements that have a Due Date no
later than the End Date of the MRP run.

Report
Length

The field is calculated automatically when
the start date and the end date are
specified. It represents the number of
periods – days or weeks respectively.
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Field

Activity/Description

Comments

Max.
Cumulative
Lead Time

An additional time interval used to extend
the time horizon after the MRP run end
date for the MRP calculation.

If you do not specify the Max.
Cumulative Lead Time, MRP does
not consider these requirements for
the MRP run.

The Max. Cumulative Lead Time period
includes the MRP-dependent
requirements for the child items in the
MRP run date range. The parent item's
due date must fall in the range of the
maximum cumulative lead time, and the
MRP requirement for its child items falls
in the range of the MRP horizon.
Consider
Holiday
Table for
Production
Planning

Select this checkbox to let MRP consider
the holidays and weekends as defined in
the holiday table. MRP increases the lead
time accordingly for the production
process.

Example
See Appendix: Example: Maximum
Cumulative Lead Time.

SAP Business One selects this
checkbox by default.

Example
The Due Date of the production order for
the parent item is July 20, 2009. In the
Item Master Data, a 2-day lead time is
defined. According to the holidays
definition, the weekend falls on (July 1819, 2009).

Consider
Holiday
Table for
Purchasing
Planning

•

The checkbox is deselected – the
MRP requirements for the child
item are issued with a due date of
July 18, 2009.

•

The checkbox is selected – the
MRP requirements for the child
item are issued with a due date of
July 16, 2009.

Select this checkbox to consider the
holidays and weekends as defined in the
holidays table. MRP increases the lead
time for the purchasing process
accordingly.

This checkbox is deselected by
default.

Example
If the lead time of a certain purchasing
item is 4 days and there are two weekend
days in this period, MRP extends the lead
time by 2 additional days.
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To choose items for the MRP run, specify the following information:
Field/Button

Activity/Description

Code From, To

Select a range of items for the MRP report. Only the items marked as MRP
items in the Item Master Data are available for selection. When you select a
parent item, MRP automatically includes all its child items in the report.

Item Group

Select the item group to be included in the MRP run.

Properties

Choose this button to open the Properties window. Select the properties to be
included in the MRP run.

4. Set the Display Preferences for the MRP run. Specify the following information:
Field

Activity/Description

Sort by

This field defines the sorting criteria for the MRP Report. From the dropdown
list, choose one of four available sorting methods:
•

Assembly Sequence – Sorts the report from the highest level of the
BOM to the lowest level.
Example
See Example of Sort by Assembly Sequence.

•

Item Number – Sorts the report by the item number.

•

Item Description – Sorts the report by the item description.

•

Item Group – Sorts the report by the item group.

Select this checkbox to display items without actual requirements after the
MRP run. Items without requirements are items that, during the entire MRP
horizon, have a sufficient quantity and there is no need to create purchase or
production orders for them.

Display Items
Without
Requirements

5. After you define all the necessary parameters or change existing ones, to save your selection,
choose the Save Scenario button.
You can use a saved scenario in other MRP runs.
6. To execute the report, choose the Run button, skipping the Data Source step.
7. To move on to the next step, choose the Next button; to go to the previous step, choose the
Back button.

Example of Sort by Assembly Sequence
In this example, three product trees are included. The low-level code 0 represents the finished goods,
and the low-level codes 1, 2 and 3 represent subassemblies or raw materials.
Low Level Code

BOM 1

BOM 2

BOM 3

0

A

F

X

1

B

E

2

C

3

D

© SAP AG 2009

20

How to Configure and Use MRP

When you select the Sort by Assembly Sequence option, the sort is carried out according to the lowlevel code, with the result as follows: A, F, X, B, E, C, and D.

Step 3 – Data Source Window
In the Data Source window, you specify the data sources for the MRP run to determine which
parameters to consider in the MRP quantity calculation (as shown in The MRP Process in SAP
Business One).

Procedure
1. To consider existing inventory quantities of the warehouses in the MRP report, select the
Existing Inventory checkbox. If the checkbox is deselected, existing inventory quantities are not
considered and are not displayed in the In Warehouses table.
Note
When you select the Existing Inventory checkbox, the warehouse selection table applies
only to the existing inventory data source. Only warehouses defined as Nettable on the
General tab of the Warehouses - Setup window appear. Warehouses defined as Drop
Ship are not displayed. You can expect to see recommendations for drop-ship
warehouses only if you deselect the checkbox.
The warehouse table is relevant only for the existing inventory data source. Due to the
functionality of SAP Business One, MRP does not consider warehouses of other data
sources (purchase orders, production orders, and sales orders). For instance, if
warehouse 01 is defined in a certain sales order or purchase order, and this warehouse
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is not chosen for the MRP run, the order is still going to be a part of the MRP quantity
calculation. The MRP run considers the total company requirements.
2. In the In Warehouses table, select the checkboxes of the relevant warehouses to consider their
existing inventory quantities in the MRP report.
{

By default, MRP selects only warehouses defined as Nettable in the Warehouses –
Setup window (Administration → Setup → Inventory → Warehouses).

{

Warehouses defined as drop-ship warehouses are not displayed in the table.

Specify or view the following information referring the table:
Field/Button

Activity/Description

Location

The location of the warehouse.

Warehouse Code

The code of the warehouse.

Whse Name

The name of the warehouse.

Expand

Expands the details of the warehouses.

Collapse

Collapses the details of the warehouses.

3. Specify the following information:
Field

Activity/Description

Purchase Orders

Select this checkbox to consider open
purchase orders in the report as expected
receipts.

Sales Orders

Select this checkbox to consider open sales
orders as requirements in the MRP run.

Production Orders

Select this checkbox to consider production
orders in the report as expected receipts.

Min. Inventory
Level

Select this checkbox to consider the On
Hand quantity according to the minimum
inventory level. MRP subtracts the minimum
level quantity from the existing inventory.

Forecast

In the dropdown list, choose a relevant
forecast for the MRP run.

Comments

Minimum inventory level is
considered in the Gross
Requirements row in the MRP
Results Window – Expanded
View.

4. To save the changes or to save a new scenario, choose the Save Scenario button. This button
is active only if you make changes in the window.
5. To execute the report, choose the Run button.

Step 4 – The MRP Results Window
The MRP Results window appears after you run the MRP wizard and displays the results of the MRP
run. This window displays the schedule for the MRP requirements, letting you view the outcome – the
recommendations, as well as the actual documents that assemble the requirements.
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Note
The outcome of the wizard is a list of the recommendations for production or purchase
orders only. To issue actual orders, from the saved recommendations for a given
scenario, you must use the order recommendation function (see Creating Order
Recommendations).

Procedure
1. View the following information:
Field

Activity/Description

Planning Horizon

Displays the dates of the MRP period as defined in the Scenario Details
window.

Calculated at

Displays the date and the time of the current MRP run.

Display after MRP

Displays data after the MRP run, including the effect of implementing the
newly recommended quantities. If this checkbox is deselected, the results
show the pre-MRP run situation, without calculating the newly planned
quantities.

To locate a certain item row in the window, Enter a value in the Find Item No. field.
2. To switch between collapsed and expanded views, click
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MRP Results Window – Collapsed View
The collapsed view is the default view of the MRP Results window.

Procedure
1. View the information in the table of the MRP Results window – Collapsed view:
Field

Activity/Description

Item No.

Displays the number of the parent and child
items.

Item Description

Displays the description of the item.

Historic Data

The total quantity of Initial Inventory,
receipts, gross requirements, and final
inventory before the start date of the
planning horizon.

There are no order
recommendations issued for
requirements that occurred in the
past (before the present day).

Past Due

Displays one of the following:

If the MRP run results in negative
ending inventory for a specific
item in the past due period, MRP
does not recommend making or
buying items for that period. The
negative inventory is passed on
to the current period (next after
past due).

•

Data sources for the MRP run (for
example, existing sales orders,
production orders, or forecasts) with
open quantities and a due date
between the start date (if earlier than
current date) and the current date
(not including the current date)

•

Requirements with past due dates
generated during the MRP run

•

The forecast from the current date
onwards. If a forecast is defined for
the period between the planning
horizon start date and the current
date, it is not included in the
requirements in the Past Due
column.

Comments

Note
To display the Item Group field, click
(Form Settings) in the toolbar. You can also
define whether to display the column headers for the MRP results in an abbreviated or
long format.
2. The right side of the table represents the MRP horizon periods as defined in the scenario.
{

If the data is grouped into periods of several days, the title of each column displays the
first day of the period in the chosen format.

{

If the data is grouped into periods of weeks (for example, a period of 4 weeks), the title of
each column displays the first week of the period in the chosen format.

3. To move the columns in this side of the table, use the scroll bar at the bottom of the table.
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4. The fields display the quantity to be ordered as recommended by the MRP run. The cells in the
table are different colors to provide an indication of their status:
Color

Description

White

White indicates there are more receipts than
requirements; therefore, the item's quantity is
sufficient and there is no need to issue the
production or purchase recommendations.

Light Grey

There are two options for this indication:
•

The item has no data for the given period.

•

The item has a recommendation for a
purchase order or a production order and,
according to the item's lead time (defined in
the Item Master Data window), there is
sufficient time to produce or to purchase the
item. In this case, the quantity appears in
black.

MRP always calculates sufficient lead time taking
the present date into consideration.

Dark Grey

Represents the periods where there is not sufficient
time to complete the production or purchase order.
The cells are dark grey regardless of the
requirements for production or purchase orders in
these periods.
If there are requirements for the production or
purchase orders in these periods, the quantity is in
red. The recommendation for the item is issued
anyway with the remark 'Past Due’. The 'MRP
Dependent Requirements' are also issued for the
child item.
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Example

•

Today is July 1, 2009.

•

A production order for a
certain parent item is due
on July 20, 2009.

•

The lead time of the item is
5 days.

The order for the child items
should be issued on July 15,
2009 (as shown in the MRP
process diagram). This is a future
date, so there is sufficient time to
complete the production.
•

Today is July 14, 2009.

•

The lead time of the item is
3 days; hence, the cells for
July 14, 15 and 16 are
dark grey.

To complete the order by the due
date of July 16, 2009, the
production or purchase orders for
the children should have been
issued on July 13. This date is in
the past; therefore, the process
cannot be completed on time and
the cell is dark grey.
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Example of a Production Bill of Materials

General Data
•

Lead time for the parent item: 2 days

•

Lead time for the child item: 2 days

•

There is no lead time for the grandchild.

•

There is a requirement for a sales order for 5 pieces of the parent item on 17 July 2009.

•

There are no other requirements or receipts for any of the items in the bill of materials.

•

Start Date: July 14, 2009

•

End Date: July 17, 2009

•

Present Date: July 14, 2009

The MRP Wizard Results
Child items lead time

Parent item lead time

Present Date: July 14, 2009

Item No.

Historic Data

Past Due

07/14/2009
(today)

07/15/2009

Parent

07/17/2009
5 pieces
(black)

Child
Grandchild

07/16/2009

5 pieces
(red)
5 pieces
(black)

To meet the sales order demand, a recommendation for a production order for 5 pieces is issued for
the parent item on July 17.
To produce 5 pieces of the parent item you require 5 pieces of the child item. Therefore, the MRP run
issues an MRP requirement for 5 pieces of the child item. Since the lead time of the parent item is 2
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days, the child item should be available on July 15 to complete the production order on time. The
recommendation for 5 pieces of the child item is issued on that date.
The lead time of the child item is also 2 days, so an MRP requirement for the grandchild should have
been issued on July 13. Even though this date is in the past, and there is no time to complete the
order for the child item, MRP issues a requirement for the grandchild.

Example of Planning Policy
This example explores how the planning policy (as shown in the MRP process diagram) would affect
the MRP run described above.
•

Order Multiple of 3 is defined in the Item Master Data of the parent item.

•

Start Date: July 14, 2009

•

End Date: July 17, 2009
Child items lead time

Parent item lead time

Present Date: July 14, 2009
Item No.

Historic Data

Past Due

07/14/2009
(today)

07/15/2009

07/16/2009

Parent

07/17/2009
6 pieces
(black)

Child

6 pieces
(red)

Grandchild

6 pieces
(black)

Five pieces are required to meet the demand of the sales order. The planning policy is for 'Multiples of
3' for the parent item. A recommendation for a production order of 6 pieces is issued.
Therefore, an MRP requirement for the child item is also for 6 pieces.
The lead time of the child item is also 2 days, so an MRP requirement for the grandchild should have
been issued on July 13. Even though this date is in the past, and there is no time to complete the
order for the child item, MRP issues a requirement for the grandchild.
Additional information for the example above:
•

An Order Interval of every 2 days was defined in the Item Master Data of the parent item.

•

An Order Multiple of 4 was defined in the Item Master Data of the child item.
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Child items lead time

Parent item lead time

Present Date: July 14, 2009
Item No.

Historic Data

Past
Due

07/14/2009
(today)

Parent

07/15/2009

07/16/2009

07/17/2009

6 pieces
(black)

Child

6 pieces (red)

Grandchild

6 pieces
(black)

Order intervals are designed to set particular days to execute the purchase or production orders,
according to the selected interval (2 days in this example). Order intervals are always counted from
the Start Date forward. In this example, the 'order days' are every 2 days: July 14 (Start Date) and July
16.
A sales order should be supplied on July 17, but this is not one of the 'order days'. Therefore, MRP
groups this recommendation to the closest 'order day' (before July 17) – in this case, it is July 16. The
recommendation for 6 pieces is shifted to this date and MRP recommendation for the child item is
issued two days earlier, on July 14.
Note that multiples of 4 were defined in the Item Master Data of the child item, so the child item should
have had the quantity of 8 accordingly. In spite of that, the quantity is still 6 since the production of the
child item cannot be completed on time according to its lead time (the quantity appears in red).
Note
No planning policy is performed on items whose quantity appears in red (production of
the item cannot be completed on time, according to its lead time).
The lead time of the child item is also 2 days, so an MRP requirement for the grandchild should have
been issued on July 12, 2008. Even though this date is in the past, and there is no time to complete
the order for the child item, an MRP requirement for the grandchild is issued.
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MRP Results Window – Expanded View
Each row in the table can be expanded into 4 additional rows by choosing
(Expand). The expanded
table displays a detailed list of what assembles the final MRP quantity (displayed in the MRP Results
Window – Collapsed View).

Each row represents one of the following data sources (as shown in The MRP Process in SAP
Business One):
Field

Activity/Description

Initial Inventory

Displays the initial quantity in stock of the
item, for every given period. This quantity is
based on the existing inventory of the
current date. For every other period, the
initial inventory derives from the final
inventory of the previous period.

Receipts

Displays the expected positive entries of
the item to the stock: purchase orders,
production orders (for the parent item) and
A/P reserve invoices.

If there is a quantity in one of the
cells in the Receipts row, it is
possible to see the detailed list of
data sources. For more information,
see Pegging Information for Receipts.

Gross
Requirements

Displays the expected inventory releases of
the item for the column’s time period: sales
orders, forecast, production orders (for child
items), A/R reserve invoices and minimum
inventory level.

If there is a quantity in one of the
cells in the Gross Requirements row
it is possible to see the detailed list of
data sources. For more information,
see Pegging Information for Gross
Requirements.
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Field

Activity/Description

Comments

Final Inventory

If the Display After MRP checkbox is
selected, this field displays the remaining
quantity after the MRP recommendations
are issued.
If the Display After MRP checkbox is
deselected, this field represents the final
quantity calculated according to the initial
inventory, receipts, and gross requirements,
without considering the MRP
recommendations.

Example of MRP Results Window – Expanded View
General Data
•

There is a requirement for a sales order for 5 pieces of item B001 on 15 July 2009.

•

Order Multiple of 3 is defined in the Item Master Data of this item.

•

There is no lead time for the item.

MRP Results – Expanded View
Item No.

Historic Data

Past Due

07/14/2009
(today)

07/15/2009

07/16/2009

07/17/2009

6 pieces

B001
Initial
Inventory

1 piece

Receipts
Gross
Requirements

5 pieces

Final
Inventory

1 piece

5 pieces are required to meet the demand of the sales order, but since there is a planning policy of
'Multiples of 3' for the item, MRP issues a recommendation for the production order of 6 pieces.
There is one piece remaining after the MRP calculation: 6 pieces from the production order in MRP
minus 5 pieces from the sales order equals 1 piece. This figure appears in the Final Inventory field and
is then transferred as an initial inventory to the next period – July 16, 2009.
Note
1 piece appears in the Initial Inventory field for July 16, 2009 only if there are
requirements for this period. Otherwise, this figure appears only in the closest period that
has requirements.
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Pegging Information for Receipts
Procedure
1. To open the receipts Pegging Information – XXX (MRP scenario name) window, click a cell
displaying an amount in the Receipts row in the MRP Results window.
The Pegging Information window opens. The title of the window shows the scenario name.

2. View the following information:
Field

Activity/Description

Item Number

Displays the number of the parent and child items.

Description

Displays the item description.

Period, To

Displays the first and the last date of the period the pegging information
relates to.

List of stock issues within this period
Source

Displays the number of the document.

Type

Displays the document type: production order, purchase order, or A/P
reserve invoice.

Due Date

Displays the due date of the production order, the purchase order, or the
AP reserve invoice.

Quantity

Displays the open quantity of the item from the production order or the
purchase order.

3. To close the window, choose the OK button.
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Pegging Information for Gross Requirements
Procedure
1. To open the receipts in the Pegging Information – XXX (MRP scenario name) window, click a
cell displaying an amount in the Gross Requirements row in the MRP Results window.
The Pegging Information window opens. The title of the window shows the scenario name.

2. The header of the window is similar to that of the Pegging Information for Receipts window; it
displays the Item Number, Description, and the first and last date of the period this pegging
information relates to.
3. View the following information:
Field

Activity/Description

Source

Displays the following:
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•

The number of production orders (relevant for
child items)

•

The number of sales order

•

Name of the forecast

•

Parent item number for an MRP-dependent
requirement for production of the parent

•

Item number for the minimum inventory level

Comments
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Field

Activity/Description

Type

Displays the type of the requirement:

Due Date

Quantity

•

Sales order

•

Production order

•

A/R reserve invoice

•

Minimum inventory level

•

Forecast demand

•

MRP requirement

Displays the due date of the sales order, production
order, or A/R reserve invoice. The Due Date field in
the forecast displays the demand date for the
current period. If the source is an MRP requirement,
the calculated due date of the parent item is
displayed.

Comments

Example
There is an MRP
recommendation for a
production order on 15
July 2009. The due date of
the MRP requirement for
the child item will be on 15
July 2009 regardless of
the period related to this
requirement.

Displays the open quantity of the item from sales
orders and planned quantity from production orders.
For a forecast, the field displays the quantity that
was not considered by the quantities of items sold in
sales orders.

Note
When there are gross requirements for an item that is an assembly or a sales bill of
materials, MRP issues no actual recommendations for production for the parent item.
MRP generates a compensation entry in the item’s Receipts row to clear the final
quantity.
MRP dependent requirements for the child items are issued regularly, similar to a
production bill of materials.
4. To close the window, choose the OK button.
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MRP Results Window – View Recommendations

Procedure
1. After viewing the MRP results, you can generate a list of the MRP recommendations. To do this,
choose the View Recommendations button.
This window displays a list of the recommended production or purchase orders you should issue
according to the MRP calculation. The values in the window are informative only, thus, you
cannot make any changes to the contents of the fields, nor can you issue any actual production
or purchase orders from the list.
To issue actual orders, according to the saved recommendations for the given scenario, you
use the Order Recommendation window. For information, see Creating Order
Recommendations.
2. View the following information:
Field

Activity/Description

Order type

Displays the type of the MRP recommendation:
production or purchase order

Item No.

Displays the number of the item

Item Description

Displays the description of the item

Quantity

Displays the quantity recommended by MRP. For
purchase orders, the quantity is displayed in the
purchasing UoM.

UoM

Displays the purchasing unit of measure for
production or purchase orders (as defined in the
Item Master Data → Purchasing Data tab)
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Field

Activity/Description

Comments

Release Date

The date on which the production or purchase
order should be released to meet its due date,
depending on the lead time of the item.

The date in this field cannot
be earlier than today.

Due Date

Displays the suggested due date for the
production or purchase orders. If the
recommended order is past due, according to the
items' lead time, the due date appears in red.

Example
•

Today is July 15,
2009.

•

The child item's
procurement method
is 'Buy' and it has a
lead time of 3 days.

The due date of the
purchase order is July 16,
2009. Although this date is in
the future, it is still red. There
is not enough time to receive
the order according to the
child item's lead time (July
13, 2009, which is 3 days
before the due date and is in
the past).
Vendor Code

Displays the preferred vendor code of the item (as
defined in Item Master Data → Purchasing Data
tab → Preferred Vendor).

Unit Price

Displays the price from the price list linked to the
preferred vendor. Note that if special prices are
defined for the linked preferred vendor, these are
displayed instead (according to the standard
behavior of prices in SAP Business One).

Discount %

Displays the discount defined for the item’s price
list

Price After
Discount

Displays the unit price after subtracting the
discount

Whse

Displays the item's default warehouse code. It is
possible to choose a different warehouse in the
Order Recommendation window.

Total

Displays the order's total amount according to the
Quantity * Price After Discount

Exception

Displays the remark "Past Due" for orders, which
are past due according to the lead time definitions
(their due date is red)

Note
To display additional fields, choose
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3. To save the recommendations for the current MRP run, choose the Save Recommendations
button.
SAP Business One saves recommendations for each scenario.
If there are previous recommendations for the current scenario, the system displays the
following message:

To save the new recommendations, choose the Yes button.
To go back to the MRP Results window, choose the No button.
4. To exit the wizard, choose the Finish button. If the results are not saved, the system displays the
following message:

Choose one of the buttons displayed:
{

Yes – saves the recommendations and exits the MRP wizard.

{

No – exits the MRP Wizard without saving.

{

Cancel – goes back to the View Recommendation window without saving.

5. To review and create actual production or purchase orders from the MRP Results window, use
one of the following methods:
{

Right-click the header area and choose Order Recommendation.

{

From the Goto menu, choose Order Recommendation.
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Creating Order Recommendations
You use the Order Recommendation – Selection Criteria window to specify selection criteria to filter
the recommendations that were created during the last MRP run for the selected scenario. The
window displays the results of the last MRP run, deleting the results of the previous one.

Procedure
1. From the SAP Business One Main Menu, choose MRP → Order Recommendation.
The Order Recommendation – Selection Criteria window opens.

2. Specify the following information:
Field

Activity/Description

Order Type

Specify the type of MRP recommendation you
would like to display in the report. In the dropdown
list, choose Production Orders or Purchase
Orders. To display them both in the report, choose
All.

Scenario

MRP recommendations are saved for each
scenario. Specify the scenario you would like to
view in the report.

Due Date From,
To

Filters the report according to the due date of the
orders

Items

Standard item selection fields, similar to other
reports in SAP Business One

© SAP AG 2009

Comments

The scenarios checked as
'Simulation' are not available
for selection.
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Field

Activity/Description

Comments

Vendors

Standard vendor selection fields, similar to other
reports in SAP Business One

Note that the vendors you
select here relate to the
Preferred Vendor field (can
be defined in Purchasing
Data tab page – choose Item
Master Data → Purchasing
Data tab).

3. To display the Order Recommendation, choose the OK button.
The Order Recommendation window opens.

Note
The Order Recommendation window is similar to the MRP Recommendation window that
can be displayed from the MRP wizard. However, unlike in the wizard, here you can
access, update, and change almost all the fields. You must enter data in all the active
fields to create production or purchase orders.
4. View or specify the following information:
Field

Activity/Description

Comments

Find

Use this field to locate a certain item row.

The value you search by is
determined by the column you
choose to use as the sorting
criteria.

Create

Select the checkboxes under this column next
to every production or purchase order you
would like to create from the recommendations.

Order Type

From the dropdown list in this field, choose the
type order: purchase order or production order.
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Field

Activity/Description

Comments

Item Number

Displays the number of the item. You can
change the item number. To select an
alternative item, right-click the Item Number
field and choose Alternative Items.

A relevant message is displayed
if there are no such alternative
items defined for this item.

Quantity

Displays the quantity recommended by MRP.
For purchase orders, the quantity is displayed in
the purchasing UoM. You can specify a different
quantity if required.

Due Date

Displays the suggested due date for the
production or purchase orders. If the
recommended order is past due, depending on
the item's lead time, the due date appears in
red. You can update the due dates manually as
required.

Vendor Code

Displays the preferred vendor code of the item.
You can choose a different vendor or select one
manually.

Unit Price

Displays the price from the price list linked to
the preferred vendor. Note that if special prices
are defined for the linked preferred vendor,
these are displayed instead (depending on the
standard behavior of prices in SAP Business
One). You can update the price manually.

Discount %

Displays the discount defined for the price list of
the item. If you change this field, the Price After
Discount and the Total fields are updated
accordingly.

Whse

Displays the item's default warehouse code.
You can choose a different warehouse if
necessary.

You choose the default
warehouse as follows:
•

For 'Buy' items, choose the
warehouse based on the
definitions on the Inventory
Data tab in the Item
Master Data window. If
there is no default
warehouse for the item,
this information derives
from General Settings →
Inventory tab → Default
Warehouse.

•

For 'Make' BOM items the
default warehouse is
based on the BOM
definition.

Note
The information described above relates only to the active fields. For information on the
informative fields, see MRP Results Window – View Recommendations.
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5. You can make several definitions and display additional fields by choosing
in the toolbar.

(Form Settings)

Specify the following information:
Field

Activity/Description

Consolidate
Recommendations

Select this checkbox to group the
recommendations for the purchase orders
related to the same vendor into one
document. If the recommendations have the
same vendor, item, warehouse, and delivery
date, they are grouped into the same row in
the purchase order document.

Consider Holiday
Table for Production
Planning

Select this checkbox to increase the lead time
for the production process according to the
holiday definition (see Step 2 – Scenario
Details Window).

Consider Holiday
Table for Purchase
Planning

Select this checkbox to increase the lead time
for the purchasing process according to the
holiday definition (see Step 2 – Scenario
Details Window).

Production Order
Series

In the dropdown list, choose a numbering
series for the production orders.

Purchase Order
Series

In the dropdown list, choose a numbering
series for the purchase.
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The default series is the
one that was defined as
such in the Document
Numbering window.
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6. After reviewing the Order Recommendation, in the Create column, select the checkboxes to
specify which production or purchase orders you actually want to create.
7. To create the selected orders, choose Update.
If you create orders, a system message appears that states how many orders were created.
Note
The string "MRP" is entered automatically in the Origin field in the created production
orders. The string "Origin: MRP" is entered automatically in the Remarks field in the
purchase orders created.
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Printing MRP Recommendations
With SAP Business One you can print MRP recommendations using default print templates.

Procedure
1. In the Tools menu, choose Print Layout Designer, or click

in the toolbar.

2. Choose the preferred printing template.
3. From the File menu, choose Print, or click

in the toolbar.

Note
You can edit the default templates or create new ones by using Print Layout Designer.
For more information about Print Layout Designer, see the document How to Customize
Printing Layouts with Print Layout Designer in the documentation area of the SAP
Business One Customer Portal at
http://service.sap.com/smb/sbocustomer/documentation.
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Authorizations
For information about the authorizations required for MRP, see the online help for SAP Business One
and the document How to Define Authorizations in the documentation area of SAP Business One
Customer Portal at http://service.sap.com/smb/sbocustomer/documentation.
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Database Tables Reference
For information about the tables used in MRP, see the .chm file: Database Tables Reference. You can
download it from the SAP Community Network.
To download the Database Tables Reference .chm file:
...

1. Go to https://www.sdn.sap.com/irj/sdn/businessone.
2. Under BUSINESS ONE KNOWLEDGE CENTER, click the link of the SAP Business One
release version you want.
3. Click the SDK Help Center link.
4. In the File Download window, do one of the following:
{

To open the .zip file, choose the Open button; then extract the REFDB.chm file to your
computer.

{

To save the .zip file to your computer, choose the Save button. You can open the .zip file
and extract the REFDB.chm file later.
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Appendix
Example: Procurement Method
•

A box of chocolates is a parent item in a production BOM, composed of a wooden box and 25
chocolates as child items.

•

The box is purchased from an external vendor and the chocolates are produced by your
company.

The 'Make' procurement method should be chosen for the box of chocolates item and the chocolate
items and a 'Buy' procurement method for the wooden box. As a result, to make one box of
chocolates, MRP issues the recommendations for quantities needed to assemble the product, which is
a production order for 25 chocolates and a purchase order for one wooden box.

Example: Consumption Method
This is an example of a sales forecast and its consumption by a sales order.
The Backward- Forward method of the forecast consumption was selected with a range of 10 days
backward and forward.
The forecast was defined as follows:
Item No.

01/15/09

01/16/09

02/15/09

03/01/09

TAB2004

10

20

20

40
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The following sales orders were received:
Document No.

Item No.

Due Date

Quantity

Consume Forecast

Result

(from the Sales Order)
10001

TAB2004

01/01/2009

5

YES

No forecast found
in the defined
range.

10002

TAB2004

01/06/2009

5

YES

5 pieces are
subtracted from
01/15.

10003

TAB2004

01/16/2009

100

NO

An additional
unexpected
requirement,
which is not on
the account of the
forecast.

10004

TAB2004

01/20/2009

20

YES

20 pieces are
subtracted from
01/16.

10005

TAB2004

02/25/2009

30

YES

20 pieces are
subtracted from
02/15 and 10
pieces are
subtracted from
03/01.

Note
The calculation is always done from the earliest sales order to the latest according to
their due dates.
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The forecast represents the company's projection for future sales. If there is an actual order on the
account of the forecast, the sales order replaces it. Only the forecast that was not ‘consumed’ by the
sales order is considered during the MRP run, as displayed in a table below.
The forecast after consumption
Item No.

01/15/08

01/16/08

02/15/08

03/01/08

TAB2004

5

0

0

30

Net Requirements ( Forecast + Sales Orders)
Item No.

01/01

01/06

01/15

01/16

01/20

02/25

03/01

TAB2004

5

5

5

100

20

30

30

Example: Maximum Cumulative Lead Time
•

The MRP horizon starts on June 1 and ends on August 31.

•

The maximum cumulative lead time is one month.

•

A sales order's due date of a certain parent item falls in the middle of September (falls in the
range of the maximum cumulative lead time).

•

The lead time of the parent item (as defined in the Item Master Data) is 25 days.

The requirements for the child item fall into the range of the MRP horizon. In this case, the
requirements (orders) for the child item are issued during the current MRP run.
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Copyrights, Trademarks, and Disclaimers
© Copyright 2009 SAP AG. All rights reserved.

The current version of the copyrights, trademarks, and disclaimers at
http://service.sap.com/smb/sbocustomer/documentation is valid for this document.
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