How to Create User-Defined Fields and Tables

Applicable Release:

SAP Business One 8.8

All Countries
English
July 2009
Table of Contents

Creating User-Defined Fields and Tables ................................................................. 3

Menus ......................................................................................................................... 4
  Tools Menu ............................................................................................................. 4
  View Menu ............................................................................................................. 6

Managing User-Defined Fields .............................................................................. 7
  Creating User-Defined Fields ................................................................................ 7
  Linking a User Table to a User-Defined Field ....................................................... 15
  Creating Table Keys ............................................................................................... 17
  Updating User-Defined Fields .............................................................................. 18
  Removing User-Defined Fields ............................................................................ 18
  Displaying User-Defined Fields ........................................................................... 19
     Displaying Header User-Defined Fields ............................................................ 19
     Modifying the Display of User-Defined Fields .................................................. 20
     Displaying Row User-Defined Fields ............................................................... 22
  Entering Values in User-Defined Fields ............................................................... 23

Managing User-Defined Tables .............................................................................. 26
  Creating User Tables ............................................................................................. 26
  Adding Fields to User-Defined Tables ................................................................. 28
  Entering Values in User-Defined Tables ............................................................... 29
     Showing and Hiding Fields ............................................................................... 30
  Removing User-Defined Tables .......................................................................... 31

Copying Fields/Tables to a New Company .............................................................. 32

Authorizations ......................................................................................................... 33

Copyrights, Trademarks, and Disclaimers ............................................................... 34

© SAP AG 2009
Creating User-Defined Fields and Tables

SAP Business One provides a comprehensive set of tables and fields in each of its modules. However, if your company requires additional tables and fields for its day-to-day work, SAP Business One enables you to create your own user-defined fields in existing system tables or your own user-defined tables.

User-defined fields, as described in Managing User-Defined Fields, enable you to add fields to existing tables to keep track of additional information. For example, you can add a field called CarNumber to the Employee Master Data table to keep track of the license plate number for each employee.

User-defined tables, as described in Managing User-Defined Tables, can be used in one of the following ways:

- To represent business objects, such as vehicle master data, or to group logical sets of user-defined fields
- To hold valid values for other user-defined fields. You can link user tables to user-defined fields, and require users to select from the values in the tables.
Menus

This section summarizes the menus for managing user-defined fields and user-defined tables.

Tools Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User-Defined Windows</td>
<td>Opens a submenu that provides links to the forms for entering data in user-defined tables, as described in Entering Values in User-Defined Fields.</td>
</tr>
<tr>
<td></td>
<td>After opening a form, to define which fields are displayed in it, click 📂 in the toolbar.</td>
</tr>
<tr>
<td>Customization Tools Submenu</td>
<td></td>
</tr>
<tr>
<td>User-Defined Tables - Setup</td>
<td>Enables you to add, modify, and remove user-defined tables, as described in Managing User-Defined Tables.</td>
</tr>
</tbody>
</table>
### Menu Item Description

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>User-Defined Fields - Management</strong></td>
<td>Enables you to add, modify, and remove user-defined fields, as described in Managing User-Defined Fields.</td>
</tr>
<tr>
<td><strong>Settings</strong></td>
<td>Enables you to modify how user-defined fields are displayed, as described in Modifying the Display of User-Defined Fields. This menu item is only visible when a form is open with its user-defined fields displayed.</td>
</tr>
</tbody>
</table>

**Note**

View Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User-Defined Fields</td>
<td>Displays the user-defined fields for the currently selected form.</td>
</tr>
</tbody>
</table>

After the user-defined field’s panel has been displayed once, the panel is displayed every time you open the form.

To hide the panel, click in the upper-right of the panel.
Managing User-Defined Fields

This section describes how to add and remove user-defined fields, and how to display and enter data into these fields.

Creating User-Defined Fields

When creating user-defined fields, you specify a field name and the type of data to be contained in the field. You can also specify the valid values for the field.

Procedure

1. In the menu bar, choose Tools → Customization Tools → User-Defined Fields - Management.

The User-Defined Fields - Management window opens:

The window displays a hierarchy of categories (form types) to which you can add user-defined fields. Some categories affect a single form (such as Business Partners under Master Data), while others affect multiple forms (Title and Rows under Marketing Documents).

To view all available form types, click Expand.
2. Select the category to which you want to add a field, and choose the Add button.

The Field Data window appears.

3. Specify the name and type of field by entering the following fields in the Field Data form:

   - **Title**: The field name.
     
     The Title value cannot contain spaces or special characters.
     
     A field is added to the database with the prefix U followed by the field name specified here. The full name, with the prefix, is displayed in the query generator when you view a table’s list of fields.

   - **Description**: The field display name.
- **Length**: The size of the field.
  
  If the field type is *Alphanumeric*, the length is the maximum number of characters.

  If the field is *Numeric*, the length is one more than the maximum number of digits. For example, specify 11 to allow up to 10 digits to be entered.

- **Type and Structure**: Describes the type of data to be contained in the field.
  
  The type and structure determines the type of data that can be entered into each field, and how it is displayed. For more information about how different types of fields are displayed to the user, see Entering Values in User-Defined Fields.

  The following table describes the *Type* field options, and the *Structure* field options for each type:

<table>
<thead>
<tr>
<th>Type</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alphanumeric</strong></td>
<td>A series of characters. The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Regular</strong>: Lets you enter up to 254 characters.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Address</strong>: For future use.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Telephone No.</strong>: If automatic dialing is set up, lets you dial the number by clicking it.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Text</strong>: Lets you enter:</td>
</tr>
<tr>
<td></td>
<td>- 2 GB of text in header fields</td>
</tr>
<tr>
<td></td>
<td>- 255 KB of text in row fields</td>
</tr>
<tr>
<td><strong>Numeric</strong></td>
<td>Integers up to 10 digits long. There are no structure options for this type.</td>
</tr>
<tr>
<td><strong>Date/Time</strong></td>
<td>Date or time. The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Date</strong>: Lets you enter a date.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Time</strong>: Lets you enter a time.</td>
</tr>
</tbody>
</table>

  The display format for dates and time is determined by system initialization settings, located in *Administration → System Initialization → General Settings → Display tab*. 

  ![Image of General Settings](image-url)
How to Create User-Defined Fields and Tables

<table>
<thead>
<tr>
<th>Type</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units and Totals</td>
<td>Integer and decimal numbers.</td>
</tr>
<tr>
<td></td>
<td>The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>• Rate</td>
</tr>
<tr>
<td></td>
<td>• Amount</td>
</tr>
<tr>
<td></td>
<td>• Price</td>
</tr>
<tr>
<td></td>
<td>• Quantity</td>
</tr>
<tr>
<td></td>
<td>• Percents</td>
</tr>
<tr>
<td></td>
<td>• Measure</td>
</tr>
</tbody>
</table>

The structures are identical except for the display format. The formats are determined by system initialization settings on the Display tab in Administration → System Initialization → General Settings.
<table>
<thead>
<tr>
<th>Type</th>
<th>Description / Structure Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Links and images.</td>
</tr>
<tr>
<td></td>
<td>The following are the structure options for this type:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Link</strong>: Lets you enter a link to a file or to a Web address</td>
</tr>
<tr>
<td></td>
<td>• <strong>Image</strong>: Lets you enter a link to a picture</td>
</tr>
<tr>
<td></td>
<td>When you add a link to a file/picture, the file/picture is copied to folders specified in the initialization settings. You must specify these folders on the <strong>Path</strong> tab in <strong>Administration → System Initialization → General Settings</strong>.</td>
</tr>
<tr>
<td></td>
<td>Specify a folder for files (attachments) and another for pictures.</td>
</tr>
</tbody>
</table>

![General Settings](image)

<table>
<thead>
<tr>
<th>Identity</th>
<th>A numeric field to which values are assigned automatically, starting with 1, and increasing by 1 with each addition.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Example</strong></td>
</tr>
<tr>
<td></td>
<td>If you have 5 sales quotations, the field automatically contains the values 1, 2, 3, 4, 5 for the 5 records of sales quotations. If you delete one of the sales quotations, the next sales quotation you create is assigned a unique number that was never used before (in this example, number 6).</td>
</tr>
</tbody>
</table>
4. Specify the valid values for the field. This step is optional.

Select one or more of the following checkboxes in the Field Data form:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Set Valid Values for Field</strong></td>
<td>Specifies that there is a predefined list of valid values for this field. For this field, users must pick from a dropdown list of valid values. To enter a valid value, choose the New button and enter a value and a description.</td>
</tr>
<tr>
<td><strong>Set Default Value for Field</strong></td>
<td>Specifies that there is a default value for the field in cases where the user does not select one. Choose a default value from the list (if you provided a list of valid values) or enter a default value. This setting is mandatory when the field is defined as mandatory.</td>
</tr>
<tr>
<td><strong>Mandatory Field</strong></td>
<td>Requires that you enter a value for this field in every document or form. If you select this checkbox, you must specify a default value for the field.</td>
</tr>
<tr>
<td><strong>Set Linked Table</strong></td>
<td>Specifies that the valid values for this field are the keys (values for the Code field) in a specific user-defined table. For more information, see Linking a User Table to a User-Defined Field. If you select this checkbox, <strong>Set Valid Values for Field</strong>, <strong>Set Default Value for Field</strong>, and <strong>Mandatory Field</strong> are disabled.</td>
</tr>
</tbody>
</table>

5. Choose the Add button.
Note

The following message is displayed:

![System Message]

To add the field, click the Yes button.

If another user is logged on to the same company, the system displays the following message, listing the machine from which the user is logged on:

![Workstations]

Choose one of the following buttons:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Try again</td>
<td>Checks again for other logged-on users and if there are none, saves the field.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the save operation and returns to the User-Defined Fields – Management window.</td>
</tr>
<tr>
<td>Ignore</td>
<td>Saves the field and displays the following:</td>
</tr>
</tbody>
</table>

![System Message]

To add the new field (or update the existing field), choose the Yes button.

This action refreshes the database tables connected to this field. If you are currently working with one of these tables, the information on the form being processed is lost.
How to Create User-Defined Fields and Tables

Result

The following occurs when you add a user-defined field:

- Information about the new field (such as its name, its size, and the table to which it was added) is stored in the **CUFD** table (user field definition table).
- The field is added to the relevant table. The prefix **U_** is added to the name of the field in the database table, indicating that it is a user-defined field.

Example

- If you add a user-defined field called **Driver** to the business partners category table, the field **U_Driver** is added to the OCRD table.
- If you add a user-defined field to a sales or purchasing header, all header tables of sales and purchasing documents are updated. All tables that start with ‘O’ (**OINV**, **ODLN**, **OPCH**, and so on), have the prefix **U_** added to the name of the field in the database table.
- If you enter valid values, they are added to the **UFD1** table.
Linking a User Table to a User-Defined Field

Instead of defining valid values for a field within the field definition, you can specify that the valid values are contained in a user-defined table.

This can be helpful if you have several fields in different tables with the same valid values, or when you want to update the valid values dynamically.

Note

You can link a field to a user-defined table only.

Prerequisite

- You are adding a user-defined field, as described in Creating User-Defined Fields, and you have opened the Field Data window to define the new field.
- The field type is Alphanumeric and its structure is Regular.
- The Set Valid Values for Field and Set Default Value for Field checkboxes are not selected.

Procedure

1. In the Field Data window, select the Set Linked Table checkbox.

   ![Field Data Window]

   A new field is displayed to the right.

2. In the new field to the right, select the user table that contains the valid values for the current field.

3. Fill out the rest of the form, and choose the Add button.
Result

When the field is displayed on the user interface, a dropdown list appears when you edit the field. The Code and Name fields are displayed, and the value of the field is the Code value of the selected item.

<table>
<thead>
<tr>
<th>Leased Car</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>R984M721</td>
</tr>
<tr>
<td>2</td>
<td>BH00028M</td>
</tr>
<tr>
<td>3</td>
<td>YTFZ7F51</td>
</tr>
</tbody>
</table>

Define New: Define New
Creating Table Keys

You can set a user-defined field (or several fields together) as a key in the database table to make the field (or set of fields) unique and prevent duplicates.

Procedure

1. In the menu bar, choose **Tools → Customization Tools → User-Defined Fields - Management**.

2. Select the table for which you would like to define a key, and choose the **Keys** button.

   The *User Tables Keys – Setup* window appears.

3. To create a new key for the table, choose the **New** button. The system creates a key with the name *IX_0*.

   In the *Key Name* field, you can change this default name. You can create as many keys as you need by choosing **New**. You can also browse between the different keys by selecting them from the dropdown list.

4. In the table, select the user-defined fields you want to include in the selected key.

   **Note**

   You can define more than one user-defined field in one key.

5. Select the **Unique** checkbox.

   If the key is made up of one field, values entered for that field must be unique. If the key is made up of more than one field, the set of values for these fields must be unique.

6. Choose the **Update** button, and then the **OK** button.
How to Create User-Defined Fields and Tables

Updating User-Defined Fields

To update a user-defined field, do the following:

2. Select a field by clicking it.
3. Choose the Update button.

The Field Data window appears. You can update the field settings except for Title, Type, and Structure.

Removing User-Defined Fields

⚠️ CAUTION
This action is irreversible and deletes all values saved in this field in all its related objects. A query with a removed user-defined field displays an error when you run it.

🔍 Recommendation
Before you remove a user-defined field, back up the database.

To remove a user-defined field, do the following:

2. Select a field by clicking it.
3. Choose the Remove button.
Displaying User-Defined Fields

After creating user-defined fields, you can display them while working in the relevant forms.

For example, if you added the field Car Number to the Business Partner category, you can display the field in the Business Partner Master Data form.

Displaying Header User-Defined Fields

Header user-defined fields are displayed in a panel on the side of the main form.

Procedure

1. Open a form with header user-defined fields, for example, Business Partner Master Data.
2. In the menu bar, choose View → User-Defined Fields.

The system displays the user-defined fields in a panel next to the form.

The panel displays all the header user-defined fields for the current form that are set as visible. For more information about showing/hiding fields, see Modifying the Display of User-Defined Fields.

To change the location of the user-defined fields panel, use the icons in the upper-left corner of the panel.

To close the panel, click ❌.
Modifying the Display of User-Defined Fields

You can modify the way user-defined fields are displayed. For example, you can choose which fields are to be displayed and in what order.

User-defined field settings are saved separately for each user and for each form.

Prerequisite

A form is open with the user-defined fields panel displayed. For more information, see Displaying Header User-Defined Fields.

Procedure

1. In the menu bar, choose Tools → Customization Tools → Settings.

The Settings – Fields – Setup... window appears:
2. Configure the settings for each field.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>The display name of the field.</td>
</tr>
<tr>
<td>Visible</td>
<td>Specifies whether the field is to be displayed or hidden.</td>
</tr>
<tr>
<td>Active</td>
<td>Specifies whether a user can edit the field.</td>
</tr>
<tr>
<td>Order</td>
<td>Specifies the display order of the fields.</td>
</tr>
<tr>
<td></td>
<td>The number must be an integer. The field with the lowest number is displayed first; the one with the highest number is displayed last.</td>
</tr>
<tr>
<td>Category</td>
<td>Assigns the field to a category.</td>
</tr>
<tr>
<td></td>
<td>You can filter the user-defined fields so only fields in a specific category are displayed using the dropdown list at the top of the user-defined fields panel:</td>
</tr>
</tbody>
</table>

**Example**

You have many user-defined fields and you would like to display different sets each time you need to display user-defined fields. You can create a couple of categories for different user-defined fields and change the displayed category when necessary.

To define a new category, choose Define New from the dropdown list.

3. Choose the OK button.
Displaying Row User-Defined Fields

Row user-defined fields automatically appear in their relevant form tables, just like system fields, and are managed in the same way. You can make user-defined fields visible and active using the *Form Settings* window. Click in the toolbar, and select the *Table Format* tab.

By default, each new row user-defined field appears at the end of the list of fields and is set to be visible and active.
## Entering Values in User-Defined Fields

The following section explains how to enter values for different types of user-defined fields:

- **Standard Field** (alphanumeric and numeric, with no valid values): Select the field and enter a value manually.

  ![Standard Field Example](image)

- **Field with Valid Values/Linked to a User-Defined Table**: Select the field to open a dropdown list, and select a value.

  ![Field with Valid Values Example](image)

- **Date Field**: Select the field to display a date, and then click the icon to display a date picker.

  ![Date Field Example](image)

- **Units and Totals**: Select the field to display a calculator, and then click the icon to display a calculator.

  ![Units and Totals Example](image)
**Image Field:** Double-click the field to display the *Open* window.

The default picture folder opens. Select a file, from this or another folder, and choose the *Open* button.

**Note**

The default picture folder is the folder defined in *Picture Folder* on the *Path* tab in *Administration → System Initialization → General Settings*. If you select a picture from a different folder, the picture is copied to the picture folder.

To replace the image, hold down the *CTRL* key and double-click the image.

To remove the image, hold down the *ALT* key and double-click the image.
How to Create User-Defined Fields and Tables

- **Link Field**: Double-click the field to display the *Open* window.

The default attachments folder opens. Select a file, from this or another folder, and choose the *Open* button. To link to a Web site, type a URL in the *File name* field and choose the *Open* button.

**Note**

The default attachments folder is the folder defined in *Attachments* on the *Path* tab in *Administration → System Initialization → General Settings*. If you select a file from a different folder, the file is copied to the attachments folder.

Once a file or Web site is linked to the field, a hand cursor is displayed when you hover over it.

To open the linked file or Web site, double-click the link.

To replace the link, hold down the **CTRL** key and double-click the link.

To remove the link, hold down the **ALT** key and double-click the link.
Managing User-Defined Tables

SAP Business One lets you create your own database tables, enabling you to:

- Manage sets of custom data, for example, a fleet of cars or a list of available meals. Every user-defined table automatically contains the following fields: Code (the key) and Name. You can add user-defined fields to the table to maintain additional business information.

- Maintain valid values for a user-defined field located in either a system table or a user-defined table.

  For more information, see Linking a User Table to a User-Defined Field.

Creating User Tables

To create a table, you specify just a name and description for the table. Two fields, Code and Name, are automatically created in the table.

You can add user-defined fields as you would for system tables.

Procedure

1. In the menu bar, choose **Tools → Customization Tools → User-Defined Tables - Setup.**
2. Enter information about the new table in a new row.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Name</td>
<td>The table name.</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the table.</td>
</tr>
<tr>
<td>Object Type</td>
<td>The type of table. Set to No Object.</td>
</tr>
</tbody>
</table>

**Note**

This column is relevant for working with user-defined objects (UDO). For more information, see the UDO section of the SDK Help Center, located on the SAP Community Network at [https://www.sdn.sap.com/irj/sdn/businessone](https://www.sdn.sap.com/irj/sdn/businessone).

You cannot update the Object Type field after adding a table.

3. Choose the OK button.

The user-defined table appears under the User Tables category in the User-Defined Fields – Management window.

A user-defined window for entering data is automatically created for the table. For more information, see Entering Values in User-Defined Tables.

**Note**

As with modifying user-defined fields, all users should be logged off before you add a user-defined table. For information on possible messages when adding a table, see the last step in Creating User-Defined Fields.
Result
The following occurs when you add a user-defined table:

- Information about the new table is stored in the OUTB table (User Tables).
- The prefix @ is added to the name of the table in the database table, indicating that it is a user-defined table.
- You can use this table in queries.
- If this table is linked to a user-defined field, then in the Query Generator, the user-defined field appears in bold in this table, indicating it is related to another table. You can drag this user-defined field to use the user-defined table for the query.

Adding Fields to User-Defined Tables
Create additional fields in a user table if the two default fields, Code and Name, are not sufficient for your business needs.

The process of adding fields to a user-defined table is the same as for adding fields to a system table, as described in Creating User-Defined Fields.

In the User-Defined Fields - Management window, user-defined tables are displayed in User Tables at the bottom of the list of categories. Click to display the available user-defined tables.
**How to Create User-Defined Fields and Tables**

**Entering Values in User-Defined Tables**

After creating user-defined tables, you can enter data into them.

**Procedure**

1. From the menu bar, choose **Tools → User-Defined Windows**.
   
   A submenu opens displaying a list of user-defined tables.

   ![Menu Bar and Submenu](Image)

2. Select a table. A window for the selected table is displayed.
   
   For example, the window below is for a table that holds car license numbers:

   ![Car Numbers Window](Image)

3. To enter a value, select a cell and enter the value.

   **Note**
   
   Both the **Code** and **Name** values must be unique.

4. Choose the **OK** button.
**Showing and Hiding Fields**

By default, all user-defined fields are set to *Visible* when you open the window for the user-defined table. You can choose to display a subset of the table’s fields.

**Procedure**

1. In the menu bar, choose *Tools → User-Defined Windows*, and then choose a specific table from the submenu.
   A window for the selected table is displayed.

2. Click in the toolbar.

3. On the *Table Format* tab, define which fields are to be visible and active.

4. Choose the *OK* button.
Removing User-Defined Tables

This section describes how to remove a user-defined table, including all its data.

**CAUTION**
This action deletes all the values saved in the table and is irreversible.

**Recommendation**
Before you remove a user-defined table, back up the database.

**Procedure**

1. From the menu bar, choose *Tools* → *Customization Tools* → *User-Defined Tables - Setup*.
2. Right-click the row to be removed, and choose *Remove*.

**Note**
Alternatively, select the *Description* column of the user-defined table you want to remove, and in the menu bar choose *Data* → *Remove*.

The table is removed from the list of user-defined tables.

3. Choose *Update*, and then *Yes* or *Yes to All* in the dialog box.
How to Create User-Defined Fields and Tables

Copying Fields/Tables to a New Company

You can copy user-defined fields and tables from one company database to a new company database that you create.

Procedure

1. Connect to the company in which the user-defined fields and tables – the ones to be copied to the new company – are defined.

2. In the menu bar, choose Administration → Choose Company.

3. In the Choose Company window, choose the New button.

   The Site User window appears:

   ![Site User Window](image)

   4. Enter the Site User ID and the Site Password, and then choose the OK button.

      The Create New Company window appears.

      ![Create New Company Window](image)

      5. Select the Copy User-Defined Fields and Tables checkbox.

      6. Specify the remaining information, and then choose the OK button.
Authorizations

Copyrights, Trademarks, and Disclaimers

© Copyright 2009 SAP AG. All rights reserved.

The current version of the copyrights, trademarks, and disclaimers at http://service.sap.com/smb/sbocustomer/documentation is valid for this document.