How to Customize Printing Layouts with the Print Layout Designer

Applicable Release:

SAP Business One 8.8

All Countries

English

August 2009
Introduction

The Print Layout Designer tool lets you modify and customize the SAP Business One default printing layouts according to your requirements.

You can set one layout as the default for all or some SAP Business One users and link specific print layouts to selected business partners.
**Opening Print Layout Designer**

You can open a printing layout for any document or report in SAP Business One.

To design a new layout for the document or report, make the required modifications in one of the system layouts and save your changes under a new name.

**Procedure**

1. From the SAP Business One **Main Menu**, open the required document or report, for example, *Sales → A/R → Sales Order*.

2. In the displayed window, choose **Tools → Print Layout Designer**. Alternatively, choose in the toolbar. The **Layout Designer – Selection Criteria** window opens:

   ![Layout Designer - Selection Criteria](image)

   This window displays the SAP Business One default print layouts and the user-created layouts.

3. Select a layout by clicking its name and choosing the **Edit** button or by double-clicking the name.


   **Note**


5. Select a layout on the **Layouts** tab by clicking its name and choosing the **Edit** button or by double-clicking the layout name.
6. Print Layout Designer opens:

7. Make the required changes in the layout.

8. To save the changes, close the Print Layout Designer window and when the prompt appears, enter a new name for the layout. In the future, you can save this layout using the Save button.
Defining Document Properties

The Document Properties window contains general data regarding the current printing layout.

Procedure


2. In the Document Properties window, select the General tab and specify the required data.

### Document Properties – General tab

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Document ID</strong></td>
<td>Comprises the following 3 elements:</td>
</tr>
<tr>
<td></td>
<td>• Document type</td>
</tr>
<tr>
<td></td>
<td>For example, RDR stands for sales order.</td>
</tr>
<tr>
<td></td>
<td>• Item type (2) or Service type (1).</td>
</tr>
<tr>
<td></td>
<td>• Document number in the layout sequence</td>
</tr>
<tr>
<td></td>
<td>For example, 0001 represents the first layout for this document type.</td>
</tr>
<tr>
<td><strong>Layout Name</strong></td>
<td>The name of the print layout.</td>
</tr>
<tr>
<td><strong>Language</strong></td>
<td>The language in which the document was created.</td>
</tr>
<tr>
<td><strong>Foreign</strong></td>
<td>Prints the foreign name of the currency code (Administration → Setup → Financials → Currencies → International Code) when printing a document for foreign business partners.</td>
</tr>
<tr>
<td><strong>Author</strong></td>
<td>The user who created the layout. System refers to SAP Business One default layouts.</td>
</tr>
<tr>
<td><strong>Remarks</strong></td>
<td>Enter remarks, if required.</td>
</tr>
</tbody>
</table>
3. On the *Paper Format* tab, specify the required data.

**Document Properties – Paper Format tab**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Layout Pages</td>
<td>To increase the page layout to more than one page, enter a number indicating the required number of pages.</td>
</tr>
<tr>
<td>Number of Copies</td>
<td>Enter the default number of copies for print.</td>
</tr>
<tr>
<td>Printer</td>
<td><em>Default</em> refers to your default printer as defined in Microsoft Windows. Select another printer from the dropdown list, if required.</td>
</tr>
<tr>
<td>Printer for 1st page</td>
<td>You can print the first page on a different printer.</td>
</tr>
<tr>
<td>Paper Format</td>
<td>Set the paper format for printing this specific layout. Changing the paper format automatically changes the display on the screen.</td>
</tr>
<tr>
<td>Width, Height</td>
<td>Manually set a specific paper format that is not defined in the <em>Paper Format</em> dropdown list.</td>
</tr>
<tr>
<td>Orientation</td>
<td><em>Portrait</em> is the default setting. Selecting <em>Landscape</em> extends the print layout, providing more space for fields in the repetitive area. However, fewer rows are printed on each page.</td>
</tr>
<tr>
<td>Margins</td>
<td>Add margins to the entire document. If you intend to file the document in a folder, we recommend adding a margin of 30 on the left.</td>
</tr>
<tr>
<td>Use Custom Margins</td>
<td>Margins defined in <em>Administration → System Initialization → Print Preferences</em> are automatically selected. If you want to select different margins for this document, select the checkbox and change the margins.</td>
</tr>
</tbody>
</table>
4. On the **Grid** tab, specify the required data.

![Document Properties - Grid tab](image)

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format</strong></td>
<td>Select a line style for the grid. A preview of the selected style is displayed on the right.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Enter the size of the squares in the grid (in pixels).</td>
</tr>
<tr>
<td><strong>Display Grid</strong></td>
<td>Displays the grid in the layout.</td>
</tr>
<tr>
<td><strong>Adjust to Grid</strong></td>
<td>The fields snap to the grid.</td>
</tr>
</tbody>
</table>

5. On the **Format** tab, specify the required data.

![Document Properties - Format tab](image)

**Time and Date Format**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Time and Date Format</strong></td>
<td>The selections you make on the <strong>Display</strong> tab in <strong>Administration</strong> → <strong>System Initialization</strong> → <strong>General Settings</strong> determine the default values.</td>
</tr>
<tr>
<td><strong>Time</strong></td>
<td>Set the time to 24H or 12H. You can select a specific time format for each layout.</td>
</tr>
<tr>
<td>Field Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Date</td>
<td>Set the date format for the layout.</td>
</tr>
<tr>
<td>Separator</td>
<td>Select a date and time separator for the layout. If this field remains empty, the application uses the default value.</td>
</tr>
<tr>
<td>Preview Printing Layout</td>
<td>To define the layout of the Print Preview window, select this checkbox and set a font style and size.</td>
</tr>
<tr>
<td>E-Mail Layout</td>
<td>To define the e-mail layout, select this checkbox and set a font style and size.</td>
</tr>
</tbody>
</table>

6. To add a background picture to the document, select the **Picture** tab.

![Document Properties](image)

Browse to the *Pictures Folder* (defined on the *Path* tab in *Administration → System Initialization → General Settings*) and choose the required graphic file.

To remove the selected picture, choose 🗑️.
7. To add DLL files to the layout (to enhance its functionality), select the *Extension* tab.

Browse to the *Extensions Folder* (defined on the *Path* tab in *Administration → System Initialization → General Settings*) and choose the required graphic file.

**Example**

You can e-mail the document in addition to sending it to the printer.
Structure of a Print Layout

SAP Business One print layouts contain several areas.

Page Header

The area highlighted in the figure below contains the document fields and the report header fields, including business partner, date, and document name.

The page header is printed on every page of the document or report.
Start of Report

The area highlighted in the figure below is located directly above the table titles. It is printed only on the first page of the document or report. In this area you can find, for example, the Ship From and Ship To details.
Repetitive Area Header

The area highlighted in the figure below contains the table titles and the subtotal titles. It is printed on every page of the document or report.
Repetitive Area

The area highlighted in the figure below duplicates itself according to the number of rows in the table.

<table>
<thead>
<tr>
<th>#</th>
<th>Description</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Sales Order: Rows:Item/Service Description</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **System String:**
  - Sales Order: 
  - Sales Order:
Repetitive Area Footer

In the area highlighted in the figure below you can add summaries to the table using formula fields, as well as subtotals. It is located directly under the repetitive area.

Sales Order (System)

Administration: Printing Header

<table>
<thead>
<tr>
<th>Description</th>
<th>Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales Order: Customer/Vendor Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Order: Bill to</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Federal Tax ID</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Federal Tax ID:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Order</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Order:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delivery Date</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Order: Due Date</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Employee:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Payment Terms:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales Order: Remarks</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Object Settings:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Active Manager:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Signature:</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
End of Report

The area highlighted in the figure below contains the totals, remarks, and other general document data.

It is printed only on the last page of the document or report.
Blank Area

The area highlighted in the figure below is a virtual area, which you cannot control in the layout. It enables the repetitive area to expand according to the number of table rows in the printed document.
Page Footer

The area highlighted in the figure below appears at the end of the page and contains company details. It is printed on all pages of the document.
Field Index

When you open a print layout, you see the Field Index window on the right of the screen. This window displays all the fields in the layout, including hidden fields.

To open the Field Index window, right-click anywhere in the layout and choose Display Fields Index. Alternatively, in the menu bar, choose Print Layout Designer → Display Fields Index.

- Clicking a field or area highlights it in yellow.
- Hidden fields are displayed in a light grey color.

Field Index

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find Unique ID</td>
<td>Fields are divided into areas. Within each area, the fields are sorted according to their Unique ID value. You can search for a field by its unique ID. If the field is found, it is highlighted in yellow and simultaneously selected in the layout and in the Properties window. You cannot perform sorting in the Field Index window.</td>
</tr>
<tr>
<td>Unique ID</td>
<td>An external unique identifier of each field generated upon field creation. You can update this field manually in the Properties – Field (Text) window. Note: The field type is T (text). The default contents are fixed. You cannot modify the contents.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays an icon matching the field type and source type (free text, database, formula, system variable, picture, bar code, and external data).</td>
</tr>
<tr>
<td>Content</td>
<td>Displays the field content. In the case of a formula, the entire formula is shown.</td>
</tr>
</tbody>
</table>
Defining Area and Field Properties

The Properties window relates to both area and field properties. It opens automatically when a print layout is opened and remains open unless you close it.

To open the Properties window, do one of the following:

- Right-click anywhere in the layout and choose Display Properties.
- In the menu bar, choose Print Layout Designer → Display Fields Index.
- In the Field Index window, double-click the field’s Unique ID value.

When you create a new field, the Properties window automatically displays the properties of the new field. Click any area or field to display its properties. Clicking another field changes the contents of the Properties window. The title of the Properties window displays the name of the selected field or area.

If you select multiple areas or fields, the title of the Properties window becomes Properties - Multiple Areas, Properties - Multiple Fields, or Properties – Multiple.

You can modify both field and area information in the Properties window. If you select several fields for modification, the system disables the Unique ID field on the General tab. As a result, some of the individual field or area information may be disabled, depending on the common characteristics of the selections.
Defining Area Properties

To modify an entire area:

1. Click anywhere in the area (where there are no fields).
   The system displays information relevant to the selected area in the Properties window.
2. Specify the required data on the General tab.

Properties Window – General tab

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unique ID</td>
<td>A unique identifier generated automatically on creation of a new area; can be manually updated by the user. Creating two areas with the same unique ID generates the error message: <img src="message.png" alt="" /></td>
</tr>
<tr>
<td>Height</td>
<td>The area height in pixels.</td>
</tr>
<tr>
<td>Visible</td>
<td>Renders the area visible on the screen.</td>
</tr>
</tbody>
</table>
3. To add a picture to the area, on the Content tab, choose the Browse button. Navigate to the picture folder you defined in Administration → System Initialization → General Settings → Path → Picture Folder and choose the required graphic file.

Print Layout Designer supports the file formats: jpg, gif, png, tif, pcx, tga, bif and bmp.

4. To activate automatic height adjustment of the area, on the Format tab, select the Area Height Adjustment checkbox.

The height of an area is adjusted automatically if the fields:
- At the top or bottom are blank
- Are linked to themselves
- Do not contain values
5. To align the end of report area to the end of the last page, on the Format tab select the Align to Bottom checkbox. This function is available in the End of Report area only and should not be used together with the Area Height Adjustment option.

6. To format the area borders and margins, on the Border tab, enter the required data.

Properties Window – Border tab

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Border, Margins</td>
<td>To define a border around the area, or margins for the area, enter numeric values in the Right, Left, Upper, and Low fields. These numbers set the thickness of the border in pixels.</td>
</tr>
</tbody>
</table>
7. To determine the color of the area, on the Color tab, enter the required data:

You can apply color separately to the frame, background, and grid. To select a color, choose ...
Creating Multiple Repetitive Areas

Additional repetitive areas can be created in all the print layouts.

Example

- In addition to the standard item table, print a separate table of item images in sales or purchasing documents.
- In the USA it is mandatory to print invoice details in two locations in the layout of checks for payment. The multiple repetitive areas option enables you to print this type of layout.
- You can print two different item tables in the same document and, using a formula type field, determine, which items appear in each table. For example, print a table of regular items, including a Quantity column, along with a table of labor items, with an extra description and no quantity.

Procedure

1. Open a print layout and in the menu bar, choose Print Layout Designer → Repetitive Area → Add.

   The application adds a new repetitive area to the layout, as shown in the following figure:

2. Create fields in the new area.

   Note
   
   You can add as many repetitive areas as required.

   You can sort every repetitive area. To sort a repetitive area, click inside the area you would like to sort, and in the menu bar, choose Print Layout Designer → Repetitive Area → Sort.

© SAP AG 2009
Creating New Fields

Using Print Layout Designer, you can create the following field types: free text, database, formula, system variable, picture, bar code, and external data. Each field can obtain its value from several sources. You can change the field and source types after creating the field.

Procedure

1. In the menu bar, choose Print Layout Designer → Add Field. Alternatively, in the toolbar, choose one of the following icons:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>🎨</td>
<td>Free Text</td>
</tr>
<tr>
<td>📚</td>
<td>Database</td>
</tr>
<tr>
<td>☐</td>
<td>Formula</td>
</tr>
<tr>
<td>🤔</td>
<td>System Variable</td>
</tr>
<tr>
<td>📑</td>
<td>Picture</td>
</tr>
<tr>
<td>📅</td>
<td>Bar Code</td>
</tr>
<tr>
<td>📊</td>
<td>External Data</td>
</tr>
</tbody>
</table>

After you have chosen the required field type, the system displays the cursor icon accordingly.

*Example*

If you choose to create a text field with a database as its default source, the cursor is displayed as 📚.

2. Place the cursor on the required location, and then press and drag the frame to extend the field.

*Note*

The minimum size of a field is 10x10 pixels.

The minimum size restriction applies only when creating a new field. Once a field has been created, you can decrease or increase the field size using the 4 gray squares on each corner of the field:

Place the cursor over a selected corner, drag to expand or shrink the field, as needed. You can also decrease or increase the field size using the General tab of the Properties - Field window.

*Recommendation*

After you have finished creating the field, click 🌀 in the toolbar.
Defining General Field Properties

After you have created a new field, the Properties window displays information about it. You can modify its properties to meet your requirements.

Procedure

Specify the required information on the General tab.

Properties Window – General tab

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unique ID</td>
<td>A unique identifier of each field; behaves in the same way as the unique ID of an area.</td>
</tr>
<tr>
<td>Field Type</td>
<td>There are 5 field types: text, picture, bar code, external data, and Logo. The icon you select when you create the field determines the default value of the field. You can change the field type at any time.</td>
</tr>
<tr>
<td>Link to</td>
<td>Creates a link between several fields, to determine if the system collectively displays or hides them. If a field is blank, its linked fields are not printed either. To create the link, choose the unique ID of the field to which you want to link the selected field.</td>
</tr>
<tr>
<td>Visible</td>
<td>Prints the field.</td>
</tr>
<tr>
<td>Group</td>
<td>The number of the group to which the field is linked. In a layout with no subsorts or subtotals, all the fields are linked to group 0. For more information about groups, see Defining Sorts.</td>
</tr>
</tbody>
</table>

Example

If the Total Liable field in the document is set to zero, there is no need to print the Tax, Discount, and Total fields. It is possible to link these fields to the Total Liable field by selecting the unique ID in the Link to field of each respective property window. This hides the fields when Total Liable is zero.

Note

If a linked field is not yet calculated, the field is ignored.
How to Customize Printing Layouts with the Print Layout Designer

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left, Top, Width, Height</td>
<td>The location and size of the field in the layout.</td>
</tr>
<tr>
<td></td>
<td><em>Left</em> and <em>Top</em> define location; <em>Width</em> and <em>Height</em> define size.</td>
</tr>
<tr>
<td></td>
<td>Specify different values, if needed.</td>
</tr>
</tbody>
</table>

**Note**

Hidden fields are not displayed in the Print Layout Designer window and appear in light grey in the Field Index window. However, you can display them on the screen for editing by choosing Print Layout Designer → Display Hidden Fields. Alternatively, click in the toolbar.
Defining Source Types

The Source Type field defines the data source of the field.

The available source types for text type fields are:

- Free Text
- Database
- Formula
- System Variable

The application automatically displays a default source type according to the type of field you select when creating the field. Change the source type by selecting another source type and then exiting the properties display for the selected field by clicking another field or area.

Defining Free Text as a Source Type

Use a free text source type for printing fixed remarks, notes, instructions, or comments.

To define free text as the source type:

1. In the Properties - Field window, select the Content tab.
2. In the Source Type field, select Free Text.
3. Enter the required text.

![Properties - Field (Text): F_192](image)

Note

You can enter up to 64,000 characters.
Defining Databases as a Source Type

Use a database source type to print information from a selected table and column.

To choose a database source type:

1. In the Properties - Field window, select the Content tab.
2. In the Source Type field, select Database and specify the required information.

Note

The system automatically creates fields of database source type in every system layout. You can create as many database fields as you require in your own print layouts.

Properties – Content tab, Database fields

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table</td>
<td>Select the table from which to retrieve the information printed in this field.</td>
</tr>
<tr>
<td>Column</td>
<td>Select the field you want to print in the document.</td>
</tr>
<tr>
<td>Get Description</td>
<td>Prints the field's description rather than its code.</td>
</tr>
</tbody>
</table>

Example

If you want to print the customer's channel business partner in a print layout for invoices, you should select Business Partner in the Table field and Channel BP in the Column field.

Example

If you select Business Partner in the Table field and BP Type in the Column field, SAP Business One prints the code values: C, S, or L. When you select the checkbox, the actual names of these code letters are printed: Customer, Supplier, or Lead.
### Field Name | Description
--- | ---
*Relate to* | This option is relevant for special scenarios only and requires knowledge of SQL. This field is used for retrieving data related to key records found in tables other than the table linked as default to the current print layout.

A key record is a field used as a primary key in a specific table. This key record functions as the identifier of the record, and, therefore, it is required to retrieve any additional data related to it.

#### Example

You need to print the name of a certain bank that is not linked to the table used in the current print layout. You must first create a text field of database source type using the required table. Then select a key record, such as *Bank Code*.

Next, you need to create an additional text field of database source type. Select the table again, select the required column (such as *Bank Name*), and in the *Relate to* field, enter the unique ID of the field with the key record.

When a table contains two or more key records, all its key records are required for retrieving the data.

#### Example

Identical bank codes are used in many countries. If you need to print the name of a specific bank, you need to link it to a relevant country, in addition to its relevant bank code.

#### Example

You are currently working in a print layout for incoming payments. However, you need to retrieve data (such as the business partner’s bank name) linked to the key record *Bank Code* from the *Bill of Exchange for Payment* table, rather than from the *Incoming Payments* table.

In the *Relate to* field, select the unique ID of the field containing the required key record. In this example, this is a text field of database source type containing *Bill of Exchange for Payment* in the *Table* field and *BP Bank Country* in the *Column* field. The dropdown list contains the unique IDs of all the fields situated in the same area as the current field.

This link makes the application retrieve the *Bank Code* value linked to the *BP Bank Country* field found in the *Bill of Exchange for Payment* table.

*Next Segment* | Use this field when a validation of two or more key records is required, for example, the *BP Bank Country* field and the *BP Bank Code* field.

To make this double validation, select the unique ID of the next key record field in this field. The field with this unique ID is used as the secondary validation key record.
Defining Formulas as a Source Type

1. In the Properties – Field window, select the Content tab.

2. In the Source Type field, select Formula and specify the required information.

   A formula source type field lets you display the results of certain calculations, which you can build either manually or with the formula editor.

3. Choose the Formula Editor button. The Formula Editor window opens.

4. To find the required field by its unique ID, enter the ID in Find Field.
   
   The matching field is highlighted in yellow.

   **Note**

   You can select fields from different areas as long as they are already calculated and located in an area above the calculation field.
5. To add a field to the formula in the formula area on the right side of the window, do one of the following:
   - Double-click the selected field.
   - Enter the unique ID in the formula area.

   **Note**
   If you enter an invalid unique ID, or modify the unique ID of a field used in a formula, the application generates a warning message.

6. To add numbers to the formula, enter them directly in the formula area.

7. To add an operation to the formula, select it in the *Operation* dropdown list and choose the *Insert* button.

### Formula Editor – Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Arithmetical</strong></td>
<td></td>
</tr>
<tr>
<td>Operations</td>
<td></td>
</tr>
<tr>
<td>%</td>
<td>This operation is an operator rather than a percent calculation. It displays the remainder of a division of 2 numbers, for example, 10 % 3 results in 1, since 10/3 = 3+ a remainder of 1.</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td></td>
<td>If the two variables you use are of integer type (natural numbers), the result is also an integer number. For example, dividing 10 by 3 results in 3. On the other hand, a division of a float type number (decimal fraction) by any other number results in a float type number as well, for example, dividing 10.00 by 3 results in 3.33.</td>
</tr>
<tr>
<td><strong>Abs</strong> (Number)</td>
<td>Displays the absolute value of a number.</td>
</tr>
<tr>
<td><strong>Avg</strong> (, ...)</td>
<td>Displays the average of a list of numbers.</td>
</tr>
<tr>
<td><strong>DecimalLeft</strong> (Number)</td>
<td>Displays the integer part of a numeric value up to its decimal point. For example, for a field containing the value 241.32, this operation results in the integer number 241.</td>
</tr>
<tr>
<td><strong>DecimalRight</strong> (Number)</td>
<td>Displays the decimal fraction of a numeric value. For example, for a field containing the value 241.32, this operation results in the decimal fraction .32.</td>
</tr>
<tr>
<td>Operation</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pow (Base as Number, Exponent as Number)</td>
<td>Displays a number raised by a power.</td>
</tr>
<tr>
<td>Round (Number, Decimals as Number)</td>
<td>This operation rounds a numeric value according to the number of characters selected in Field 2. For example, a field contains the value 524.18. Selecting the number '1' in Field 2 results in 524.2.</td>
</tr>
<tr>
<td>String Operations</td>
<td></td>
</tr>
<tr>
<td>Amount (Money)</td>
<td>Extracts only the number out of a field containing a value comprised of a number and a currency symbol. For example, selecting this operation for the field Amount Due containing the value €154 prints 154. This operation is mainly required in cases where a number is needed for calculation between fields.</td>
</tr>
<tr>
<td>Concat (, ...)</td>
<td>Concatenates strings. For example, &quot;A&quot; Concat &quot;B&quot; results in &quot;AB&quot;.</td>
</tr>
<tr>
<td>Currency (Money)</td>
<td>Extracts only the currency symbol out of a field containing a value with a currency symbol. For example, selecting this operation for the Amount Due field containing the value $154, prints $.</td>
</tr>
<tr>
<td>Length (Text as String)</td>
<td>Displays the number of characters in the selected field (a space is regarded as a character). For example, using this operation on a Remarks field that contains a value with 100 characters, results in the value 100 being printed.</td>
</tr>
<tr>
<td>Sentence (Text as String, SentenceIndex as Number)</td>
<td>Cuts an entire sentence from the selected field (up to the next Enter mark). In Field 2 select a number to indicate the required sentence number to cut.</td>
</tr>
<tr>
<td>Substring (Text as String, SubStringLength as Number)</td>
<td>Cuts a selected number of characters from the left of a selected field (a text field containing a number should be linked). For example, selecting Substring (Unique_ID, 2) using the unique ID of a field containing the string <code>SAP Business One</code> prints <code>P Business One</code>.</td>
</tr>
<tr>
<td>Date Operations</td>
<td></td>
</tr>
<tr>
<td>Day (Date as String)</td>
<td>Returns the day part of a date.</td>
</tr>
<tr>
<td>Month (Date as String)</td>
<td>Returns the month part of a date.</td>
</tr>
<tr>
<td>MonthName (Month as Number)</td>
<td>Returns the name of the month. You enter the number (for example, 6) and it</td>
</tr>
</tbody>
</table>
### How to Customize Printing Layouts with the Print Layout Designer

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prints June.</td>
<td></td>
</tr>
<tr>
<td><strong>Year (Date as String)</strong></td>
<td>Returns the year part of a date.</td>
</tr>
<tr>
<td><strong>Condition Operations</strong></td>
<td>To use condition operations:</td>
</tr>
<tr>
<td></td>
<td>• The condition must be IF and must consist of 2 fields.</td>
</tr>
<tr>
<td></td>
<td>• The calculation field displaying the result must be located in an area below its calculated fields.</td>
</tr>
<tr>
<td><strong>To use conditions on fields, follow these steps:</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>1. Create a text field of formula source type for displaying the result. The result is 1 if the condition is met and NULL if the condition is not met.</td>
</tr>
<tr>
<td></td>
<td>2. In the Formula field, select Formula Editor.</td>
</tr>
<tr>
<td></td>
<td>3. Select the fields for the condition by searching for them in the field index or entering them manually. You can also select hidden fields.</td>
</tr>
<tr>
<td></td>
<td>4. In the Operation field, select the condition to apply to the selected fields. (Not equal !=, Less than &lt;, Greater than &gt;, and so on)</td>
</tr>
<tr>
<td>The main use of conditions involves the link to option. If the condition is not met and the field is NULL, then none of the fields linked to it are printed.</td>
<td></td>
</tr>
<tr>
<td><strong>Cast Operations</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <strong>ToNumber</strong> (String)</td>
</tr>
<tr>
<td></td>
<td>Explicit cast from string to number.</td>
</tr>
<tr>
<td></td>
<td>• <strong>ToString</strong> (Number)</td>
</tr>
<tr>
<td></td>
<td>Explicit cast from number to string.</td>
</tr>
<tr>
<td><strong>Other Specific Operations</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <strong>ColAvg(UniqueID as String)</strong></td>
</tr>
<tr>
<td></td>
<td>A calculation of the average value of numbers in a selected column, for example, average price. This formula field can be created below the repetitive area.</td>
</tr>
<tr>
<td></td>
<td>• <strong>ColSum(UniqueID as String)</strong></td>
</tr>
<tr>
<td></td>
<td>A calculation of the total values in a selected column, for example, total quantity. This formula field can be created below the repetitive area.</td>
</tr>
<tr>
<td></td>
<td>• <strong>CopyNumber()</strong></td>
</tr>
<tr>
<td></td>
<td>Lets you manage the number of printed copies.</td>
</tr>
<tr>
<td></td>
<td>• <strong>currentPage()</strong></td>
</tr>
<tr>
<td></td>
<td>The number of the page in the document printout.</td>
</tr>
<tr>
<td></td>
<td>• <strong>date()</strong></td>
</tr>
<tr>
<td></td>
<td>The printing date.</td>
</tr>
<tr>
<td></td>
<td>• <strong>groupLineNum()</strong></td>
</tr>
<tr>
<td></td>
<td>The row number in the group for which a sort or subtotal is calculated. When you create this type of field in the repetitive area footer, for a group on which a sort is performed, the field displays the total number of rows in each subtotal.</td>
</tr>
<tr>
<td></td>
<td>• <strong>lineNum()</strong></td>
</tr>
<tr>
<td></td>
<td>The successive number of the row in the repetitive area.</td>
</tr>
</tbody>
</table>
How to Customize Printing Layouts with the Print Layout Designer

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>• PageAvg(UniqueID as String)</td>
<td>A calculation of the average value of numbers in a selected column on every printed page.</td>
</tr>
<tr>
<td>• PageSum(UniqueID as String)</td>
<td>A summary of the values in a selected column for every page.</td>
</tr>
<tr>
<td>• ReportAvg(UniqueID as String)</td>
<td>A calculation of the average value of numbers in a selected column for the entire report.</td>
</tr>
<tr>
<td>• ReportSum(UniqueID as String)</td>
<td>A summary of the values in a selected column for the entire report.</td>
</tr>
<tr>
<td>• SortFieldName(SortNumber as Number)</td>
<td>The name of the sort field selected in the layout, for example, Item Group.</td>
</tr>
<tr>
<td>• SortValue()</td>
<td>The content of the sort field selected in the layout, for example, the item group name.</td>
</tr>
<tr>
<td>• SystemString(B1Notice)</td>
<td>Select this operation to print the message: Printed by SAP Business One.</td>
</tr>
<tr>
<td>• SystemString(ContinueNextPageNotice)</td>
<td>Select this operation to print the relevant message on each page, except for the last one.</td>
</tr>
<tr>
<td>• SystemString(ContinueNotice)</td>
<td>Select this operation to print the message on each page.</td>
</tr>
<tr>
<td>• Time()</td>
<td>The printing time.</td>
</tr>
<tr>
<td>• TotalPages()</td>
<td>The total number of printed pages.</td>
</tr>
</tbody>
</table>

8. After completing the formula, choose the **Update** button.

The system generates a message to inform you that the formula has been successfully created.

If there are errors in the formula the system generates a warning message, such as:

**System Message**

Errors were found in the formula. Formula syntax error: Line 1, Column 17: "}" expected. Do you still want to save?

[Yes] [No]
Note
You can define a calculative ratio between fields using a formula field. In such a case, the formula field displaying the result must be located in an area below its calculated fields.

Defining System Variables as a Source Type

The System Variable field contains a link to an actual variable found in SAP Business One.

To choose a system variable as the source type:

In the Source Type field, select System Variable and specify the required information.

Properties – Content tab, System Variable fields

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| Variable No. | Specify the variable number. Variables are unique to the specific document you are designing. To place a text field of system variable source type, you need to know the variable number. To display the variable number in SAP Business One:  

1. In the menu bar choose View → System Information.  
2. Place the cursor on the field.  
   The system displays the field details in the status bar (located in the bottom left part of the screen).  
4. The variable number assigned to the field is displayed as Variable = <number> |

Note
The document editing functionality does not support variable fields due to the following reasons:

- Variable numbers might change after you upgrade to a higher version.
- You can use variable numbers that are not linked to the document or form related to the document editing.

You can retrieve a system variable by using the system information function. From the View menu, choose System Information.
### Field Name | Description
---|---
Comment | Enter a description of the variable. This text is not printed.

**Example**

Examples for using variable fields include:

- Data calculated during the printing process or in the actual document, for example, the *Total Before Discount* field in sales and purchasing documents
- Fields appearing as columns in a table, but which are not printed, for example, the *Credit (SC)*, *Debit (SC)* and *Balance (SC)* fields in the General Ledger report

Use one of the following methods for printing the *Price* field:

- Choose *System Variable* as *Source Type* and *Variable No. 81*.
- Choose *Database* as *Source Type* and select *Unit Price* in *Column*.

When you use the *Database* field, the application prints only the amount, but when you use the system variable, it prints the amount with the currency.

**Note**

For more information on variables available for printing, see the how-to guide *How to Use the PLD Variables File* in the documentation area of SAP Business One Customer Portal at [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation).

### Defining Picture Fields as a Source Type

Picture fields let you print the company logo, pictures of items, and even images of company employees in your documents.

**Note**

To print the company logo, you can also select the *Logo* field type on the *General* tab. This selection automatically adds the logo you defined in *Print Preferences* → *General* tab → *Co. Logo*.

The source types available for picture type fields include:

- **File** (default)
  
  Use the file source type to print a fixed image, such as the company logo, in the document.

- **Database**
  
  Use the database source type to print pictures saved in your database tables. For example, you can print a catalog of items along with their pictures.

  To associate a picture with an item, choose *Inventory* → *Item Master Data*, and on the *Remarks* tab, click 📷.

- **Bar Code**
  
  The *Content* tab of a bar code type field is identical to the *Content* tab of a text field. The source types available for bar code fields include the values *Free Text*, *Database*, *Formula*, and *System Variable*. Free text is the default source type.

- **External Data**
  
  You can use this type of field to print secured images, such as official stamps, which you are not legally permitted to save on your computer as regular pictures, but as *.dll files*. The source types available for external data fields include the values *Procedure Name*, *Database*, *Formula*, and *System Variable*. 
To select a file source type to print a fixed image, proceed as follows:

1. In the Properties - Field window, select the Content tab.
2. In the Source Type field, select File.
3. Choose the Browse button, navigate to the picture folder you defined on the Path tab in Administration → System Initialization → General Settings, and select the required picture file.

To select a database source type to print a fixed image, proceed as follows:

1. In the Properties - Field window, select the Content tab.
2. In the Source Type field, select Database.
3. In the Table field, select the required database table.
4. In the Column field, select the required field.
To select a procedure name as a source type to print a fixed image, proceed as follows:

1. In the Properties - Field window, select the General tab.
2. In the Field Type field, select External Data.
3. Select the Content tab.
4. In the Source Type field, select Procedure Name.
5. In the Procedure Name field, specify the name of the required *.dll file.

**Note**

The *.dll file must be located in the extensions folder defined on the Path tab in Administration → System Initialization → General Settings → Path → Extensions Folder.

6. To define a dependency between a hidden field in the layout and the extension's printing, do the following:
   a. In the Source Type field, select Database.
   b. In the Table field, select the required table.
   c. In the Column field, select the field on which the extension's printing depends.

A dependency could be, for example, when an extension is printed only if its linked field contains a certain number, date, or string.
Defining Field Text Formats

Use the Format tab to customize the appearance of the text in the field.

Procedure

1. In the Properties - Field window, select the Format tab.

2. Specify the required data as described in the following table.

Properties – Format tab

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font, Size</td>
<td>In the corresponding fields, select an appropriate font and manually enter the size. Choosing the Font… button opens a window in which you can change the font type, style, size, and color.</td>
</tr>
<tr>
<td>Block Overall Font Change</td>
<td>Keeps the font defined for the field, even if you try to change it from either the Preview Printing Layout or E-Mail Layout field on the Format tab in Print Layout Designer → Display Document Properties.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>Select the required horizontal alignment method.</td>
</tr>
<tr>
<td>Vertical</td>
<td>Select the required vertical alignment method.</td>
</tr>
</tbody>
</table>
How to Customize Printing Layouts with the Print Layout Designer

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Line Break</strong></td>
<td>Select a line-breaking method for fields containing long texts. For example, define how to break a long text in the Remarks field of a document, using one of the following methods:</td>
</tr>
<tr>
<td></td>
<td>• <em>Allow Overflow</em></td>
</tr>
<tr>
<td></td>
<td>Prints the text even if it crosses the frame's border.</td>
</tr>
<tr>
<td></td>
<td>• <em>Adjust to Cell</em></td>
</tr>
<tr>
<td></td>
<td>Cuts the text when the text reaches the frame's border. The remaining text is not printed beyond the border.</td>
</tr>
<tr>
<td></td>
<td>• <em>Divide into Rows</em></td>
</tr>
<tr>
<td></td>
<td>Continues the text in the next row when the text reaches the frame's border. To enable this option, we recommend maintaining spaces between words.</td>
</tr>
<tr>
<td></td>
<td>To divide into rows according to the original text, press <strong>ENTER</strong> on the keyboard each time you want a new row.</td>
</tr>
<tr>
<td><strong>Length</strong></td>
<td>Set a fixed number of characters to be printed in selected fields.</td>
</tr>
<tr>
<td></td>
<td>For example, print only the first 5 digits of an item number:</td>
</tr>
<tr>
<td></td>
<td>Original Item Number: 5822107. Printed Item Number: 58221.</td>
</tr>
<tr>
<td><strong>Filler</strong></td>
<td>Define a symbol for filling up the remaining spaces when the field contains fewer characters than defined in the Length field.</td>
</tr>
<tr>
<td></td>
<td>For example, if an item number is less than 5 characters long, the filler * is printed instead of the missing characters.</td>
</tr>
<tr>
<td></td>
<td>Original Item Number: 582, Printed Item Number: 582**</td>
</tr>
<tr>
<td><strong>Field Height Adjustment</strong></td>
<td>Automatically adjusts the field height to the text it contains.</td>
</tr>
<tr>
<td><strong>Sum in Words</strong></td>
<td>Prints in words a number displayed in a field. For example, the amount $25 is printed as Twenty-Five Dollars.</td>
</tr>
<tr>
<td><strong>Suppress Zeros</strong></td>
<td>Removes decimal zeros from a number displayed in a field. For example, 233.00 is printed as 233.</td>
</tr>
</tbody>
</table>
Defining Field Borders

Use the *Border* tab to customize the appearance of a field border.

**Procedure**

1. In the *Properties - Field* window, select the *Border* tab.

![Properties - Field window](Image)

2. Specify the data as described in the following table.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Border</em></td>
<td>Draws a border around the field. Enter numbers (pixels) in the <em>Right</em>, <em>Left</em>, <em>Upper</em>, and <em>Low</em> fields to set the thickness of the frame.</td>
</tr>
<tr>
<td><em>Margins</em></td>
<td>Enter numbers (pixels) in the <em>Right</em>, <em>Left</em>, <em>Upper</em>, and <em>Low</em> fields to set the location of the content inside the frame.</td>
</tr>
<tr>
<td><em>Shade</em></td>
<td>Enter a number to set the degree of shading.</td>
</tr>
</tbody>
</table>
Defining Field Colors

Use the Color tab to set the print color for the text, background, highlighted text, and frame.

Procedure

1. In the Properties - Field window, select the Color tab.

2. To open the Color window, choose ...

3. Select the required colors.

Note

To define the highlighted text, frame, or background color as transparent, deselect the checkbox next to the field name.
Field Dependencies

Dependency Types

These are the two types of field dependencies:

- **Formula Dependency**
  
  This dependency occurs when you create a field with a formula source type. This field may use other fields as operands. The calculated field becomes dependant on its operand fields. If you delete any of the other fields, the dependent field becomes invalid and you cannot print the document.

- **Link Dependency**

  This dependency is created by the Link to option on the General tab of the Properties window. The field becomes visually dependent on the field to which it is linked. The link affects only the visibility of the dependent field; its visibility depends on the visibility or value of the other field. If you delete the field on which it depends, the document still prints.

  The *Relate to* and *Next Segment* options also create a link dependency. A field may also be recursively dependent on another field. For example, field A depends on field B, and field B depends on field C. This makes field A recursively dependent on field C.

Displaying and Hiding Dependant Fields

You can display or hide dependent fields using commands in the menu bar or in the toolbar. Displaying dependencies highlights both visible and hidden fields in both Print Layout Designer and the Field Index window:

Displaying Dependent Fields

This command is enabled when a field or several fields in the layout are activated.

To display dependant fields:

1. Select the field whose dependent fields you want to display.

2. In the toolbar, choose 📊.

   The status bar displays one of the following messages, depending on whether or not the system found dependent fields:

   📊 No dependent fields found, 📊 (6 visible, 0 hidden) fields found.
Example

If field A is not visible, then field B should not be visible either. Therefore, a link should be created between A and B.

1. Create Field A:

2. Create Field B and link Field A to Field B so that Field B is dependent on Field A. This is a link dependency.

3. To display the fields that are dependent on Field A, select Field A and choose \textit{Display Dependent Fields}.

The application displays Field A with a dark green background color in Print Layout Designer and Field B (the link-dependent field) with a light green background color and a green border:
The dependency is highlighted in the same way in the *Field Index* window:

The application colors the *Type* column according to the dependency type.

When dependency is shown, a legend appears at the bottom of this window, displaying a square for each color.

The legend disappears when dependent fields are hidden.

The application displays formula-dependent fields with a medium green background color and a green border. In a recursive dependency, if at least one of the dependencies along the chain is a formula dependency, then the dependent fields are marked as formula dependent.

4. To show dependencies of another field, select the field and choose ![Show Dependencies](show-dependencies.png) again.

5. Choose ![Hide Dependency](hide-dependency.png) to hide the dependency.

   This icon is active only when dependencies are shown. The command de-highlights Field A and both fields revert to their original properties.
Deleting Fields

When you attempt to delete fields on which other fields depend, the application issues a warning message asking you if you want to proceed with the deletion.

Example

You have four text fields, A, B, C, and D. Field B is dependent on Field A and Field D is dependent on Field C; therefore, Fields A and C have dependencies.

1. Select the four fields and press Delete.
2. The following warning message appears:

3. Choose the relevant option, as described in the following table:

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Deletes the first field with dependencies (Field A). The warning message reappears before the second field with dependencies (Field B) can be deleted.</td>
</tr>
<tr>
<td>Yes to All</td>
<td>Deletes all fields with dependencies (Field A and C) and without dependencies (Field B and Field D).</td>
</tr>
<tr>
<td>No</td>
<td>Default. Cancels the delete operation for the first selected field with dependencies (Field A). The window then reappears to issue the same warning message for the next field with dependencies (Field C).</td>
</tr>
<tr>
<td>No to All</td>
<td>Cancels the delete operation for all fields with dependencies (Field A and Field C) but deletes the fields without dependencies (Field B and Field D).</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels the entire delete operation for all fields.</td>
</tr>
</tbody>
</table>
Defining Sorts

You can sort the printed table according to the data found in each repetitive area (including hidden fields).

Procedure

To sort a certain table in a repetitive area, do the following:

1. Click the selected area.
2. In the menu bar, choose Print Layout Designer → Repetitive Area → Sort.
3. Make selections as described in the following table:

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field Name</td>
<td>Select the sort field. The first field you select is the primary sort; the second field is the secondary sort, and so on.</td>
</tr>
<tr>
<td>Sort Type</td>
<td>Select Alpha, Numeric, Currency, or Date.</td>
</tr>
<tr>
<td>Order</td>
<td>Select Ascending or Descending.</td>
</tr>
<tr>
<td>Summary</td>
<td>Indicates to the application to search for a subsort or a subtotal when performing a summary for this sort.</td>
</tr>
<tr>
<td>New Page</td>
<td>Moves on to a new page after a summary or a sort takes place.</td>
</tr>
</tbody>
</table>
Performing Subsorts and Subtotals

You must create sorts to perform subsorts or subtotals. For example, sort the Items table in a sales quotation by the Item Number field and display a relevant title each time the item number changes. This is a subsort.

In addition, perform a subtotal displaying the cumulative quantity of each item. This is useful in documents containing multiple rows of the same item, displayed with a different description in each row.

Procedure

After defining the sort, do the following:

1. In the menu bar, choose Print Layout Designer → Group.
2. Select a group number.
3. Select 1 for a subsort or subtotal for the primary sort, select 2 for the secondary sort, and so on.
   - Each group is linked to its relevant row number in the Sort window described above. Thus, every field created in a certain group relates only to its group's corresponding row in the Sort window.
   - The titles of the repetitive area header are now hidden, as well as any field created in the repetitive area footer. The reason is that these two areas are linked to groups. Each of the groups has two areas of its own.
4. To define the subsort, do the following:
   a. In the repetitive area header, assign a title for the required sort.
   b. Create a new formula field.
   c. Choose the Formula Editor button and in the Operation field, select the operand SortValue().
      This action prints the Items table divided into separate titles each time the item number changes.
5. To define subtotals, do the following:
   a. In the repetitive area footer, create a formula field.
   b. Choose the Formula Editor button and in the Operation field (for the Quantity field from the rows in the sales quotation), select the operand ColSum (UniqueId as String).
      The field inside the brackets defines the column for which a total is calculated. You can also calculate totals for the Total column.
6. Save the changes.
How to Customize Printing Layouts with the Print Layout Designer

Setting a Default Print Layout

For each new company, SAP Business One creates default print layouts for each document and report type (according to the localization).

After creating your own user-defined layouts, you can set them as default, so that each document is printed using the customized layout.

Procedure

1. Open the required document or report.

2. Choose Tools → Print Layout Designer. Alternatively, choose in the toolbar.

   The Layout Designer – Selection Criteria window opens:

   - Choose Document Type
     - Order (Items)

   - Layout Templates
     1. Order Confirmation (EHP) (System)
     2. Order Confirmation (System)
     3. Sales Order (EHP) (System)
     4. Sales Order Blank Stock USA (System)
     5. Sales Order Preprinted USA (System)

   The document name displayed in bold letters is the current default print layout.

   In the above example, the layout Sales Order Preprinted USA (System) is set as the default layout for the document type Order (Items).

3. To set a different layout as default, click the required document name and choose the Set as Default button.

   The Default Layout window appears:

   - Set as Default for All Users
   - Set as Default for Current User
   - Set as Default for Specified Users

   - Set as Default for all EPs (for Whom a Default Layout Has Not Been Assigned)
   - Set as Default for Specified EP

   OK  Cancel
4. Set a default print layout for users and for business partners using the following options:
   o Users:
     ▪ **Set as Default for All Users**
       Sets the selected layout as default for all SAP Business One users. Only a superuser can set a layout as default for all users.
     ▪ **Set as Default for Current User**
       Sets the selected layout as default only for the SAP Business One user who is currently logged on.
     ▪ **Set as Default for Specified Users**
       Lets you select specified users from the List of Users window displayed when you choose [Select Users].
   o Business Partners:
     ▪ **Set as Default for All BPs (for whom a Default Layout has not been assigned)**
       Sets the selected print layout as default for all the business partners for whom no default layout has been assigned yet.
     ▪ **Set as Default for Specified BP**
       Lets you select specific business partners from the BP Properties window displayed when you choose [Select Business Partners].

    **Note**

    You can set a print layout as default for one or several business partners using the Business Partner – Selection Criteria window:
    1. Open the BP Properties window.
    2. Using the From and To fields, define a range of the wanted business partners.
    3. Choose the OK button.

5. Choose the OK button to apply the selections.

    **Note**

    You can set default print layouts for business partners for the following documents: sales and purchasing (invoice, delivery, and so on); payments (incoming payments, outgoing payments, and so on); checks for payment; and sales opportunity.
**Tips and Tricks**

**Backing Up Print Layouts**
Save your print layout under a new name each time you modify it. This helps in keeping backups of the user-defined layouts and lets you return to a previous layout in case the new one does not meet your requirements.

After you have made a change in a print layout and saved it under a new name, you can set the new layout as default, print the document, and see if the modifications are as required.

**Deleting Layouts**
You can delete the backup layouts at any stage by doing the following:

1. Open the required print layout.
2. In the menu bar choose *Print Layout Designer → Delete Layout*. If you delete a default layout, the application chooses another layout as the default.

   ![Note](image)
   You cannot delete SAP Business One default (System) print layouts.

**Printing the Ship-To Address and the Bill-To Address**
To display the ship-to or bill-to address in the print layout of a document, use the default values from the business partners table or from the document table (for example, delivery).

**Using Formula Fields as Sort Fields**
You can use formula fields as sort fields in the Sort window.

![Sort Window](image)

To use a formula field as a sort field, in the Field Name column, select the required formula field.
Multiple Predefined Print Layouts (System)

Some reports and document types have several SAP Business One default (System) layouts:

The number of these predefined layouts varies according to the document/report type and your localization.

Saving Layouts as Images

You can save documents and reports as graphic files (*.jpg).

To save a document as a graphic file, do the following:

1. Display the required document, for example, a sales order.
2. In the menu bar, choose File → Print Preview.
   The system displays a preview of the printed document.
3. In the menu bar, choose Goto → Save as Image.

   Note

   The application saves the file in the Picture folder defined on the Path tab in Administration → System Initialization → General Settings.

Cumulative Summary Field

You can create a field for a cumulative summary of a selected field.

Example

To create a cumulative quantity per row, do the following:

1. In the repetitive area, create a new formula field.
2. Apply the operand ColSum(var) to the selected field.
How to Customize Printing Layouts with the Print Layout Designer

Increasing the Number of Printed Rows on Each Page

To increase the number of printed rows, do the following:

1. From the SAP Business One Main Menu, choose Administration → System Initialization → Print Preferences, and on the General tab, do the following:
   a. Select Max. Rows per Page.
   b. Select Print with Vertical Compression.

   All the rows in the document are compressed according to this definition.

   To extend the blank area, reduce the height of any other area in the layout.

2. To reduce the repetitive area, reduce the fonts, the fields (including hidden ones), and the entire area.

Printing Pictures in Their Original Size

The Ext. Image Processing field sets the print style of your logo and pictures. The field is relevant when attached pictures are not printed according to their original size.

To print pictures in their original size, do the following:

1. From the SAP Business One Main Menu, choose Administration → System Initialization → General Settings.


This enables a print style that sharpens the picture's printout and reduces the printout of a text-containing logo.
Printing the Manufacturer or Group Name

To print the manufacturer or the item group name of an item or business partner, do the following:

1. In the repetitive area, add a new hidden database field.
2. In the Table field of the Properties window, on the Content tab, select Items.
3. In the Column field select Item Group.
4. Add another database field in the same area. You can now select the Item Groups in the Table field and Group Name in the Column field.

Picture Formats

You can use the following graphic formats:

- *.bmp
- *.gif
- *.jpg
- *.png
- *.tif
- *.pcx
- *.tga
- *.bif

The files must not be compressed.

Error Messages

"File name missing in data field":

The system displays this error message when you attempt to save a print layout that contains a database field with no values in the Table and Column fields.

The system highlights the relevant field in both the layout and the Field Index window to indicate where the problem is. You can remove or update the field.
"Printing Error":

When the system generates error messages related to fields in the layout, the unique ID numbers of the field(s) causing the error are displayed as part of the message:

```
Printing Error: Field does not exist (RPT: 6717) (Field: Field_309)
```

**Maintaining the Original Display Order**

After creating subtotals and subsorts, you can determine that the items inside each subsort appear in their original order, as displayed in the document.

To maintain the original display order, do the following:

1. In the repetitive area that contains the *Row Number* field from the document, create a hidden system variable field:

   ![Properties - Field (Text): F_191](image)

   - **Source Type**: System Variable
   - **Variable No.**: 77
   - **Comment**: Row Number

2. In the *Sort* window, define this field as the secondary sort.

   ![Sort...](image)
Printing Using the Page X of Y Format

To print page numbers in reports and documents in a Page X of Y format, do the following:

1. Create two formula fields using the following operands:
   - `CurrentPage()`
   - `TotalPages()`
2. Create two text fields containing the texts:
   - `Page`
   - `of`

Printing Query Parameters in User Reports

You can create user reports for your user-defined queries.

If a query contains conditions, these are printed in the report header.

**Example**

A query retrieves all the business partners with a positive account balance and uses the condition "Balance > 0.00".

When you create a user report for this query, the condition you use in the query is printed in the report header.

Printing Additional Bar Code Types

With SAP Business One you can print the most widely used bar code types: EAN 13 and Code 39.

In addition, you can print other bar code types by following the procedure below.

**Prerequisites**

You have saved the required bar code font on your computer.

**Note**

You can obtain bar code fonts on the Internet.

**Procedure**

1. To install the bar code font in the Microsoft Windows font library, from the Windows taskbar choose `Start → Control Panel → Fonts`.
2. In the menu bar choose `File → Install New Font`.
3. Navigate to the required font and choose the `OK` button.
4. In SAP Business One, open the required print layout in Print Layout Designer, create a new field, and define it as `Free Text` or `Database`.
5. In the `Properties` window of the new field, select the `Format` tab.
6. In the `Font` field, select the bar code font.
Result

When the document is printed, the content of the new field is printed as a bar code.

Note

To view the bar code when print previewing the layout and sending it through e-mail, make sure that the Preview Printing Layout and E-Mail Layout checkboxes on the Format tab in the Document Properties window are deselected.
Copyrights, Trademarks, and Disclaimers

© Copyright 2009 SAP AG. All rights reserved.

The current version of the copyrights, trademarks, and disclaimers at http://service.sap.com/smb/sbocustomer/documentation is valid for this document.